summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorblackraven <dpisklov@gmail.com>2016-03-22 23:08:29 +0000
committerIan Delaney <idella4@gentoo.org>2016-03-24 19:35:17 +0800
commite34011c28c1e3ec4c787856cd9e330f3cf815ddf (patch)
treea09339e7cab594664676429a5d725446292ccb49
parentprofiles: new input devices for roccat-tools (diff)
downloadgentoo-e34011c28c1e3ec4c787856cd9e330f3cf815ddf.tar.gz
gentoo-e34011c28c1e3ec4c787856cd9e330f3cf815ddf.tar.bz2
gentoo-e34011c28c1e3ec4c787856cd9e330f3cf815ddf.zip
sys-apps/roccat-tools: vn. bump to 3.9.0; new devices support
Closes: https://github.com/gentoo/gentoo/pull/1116
-rw-r--r--sys-apps/roccat-tools/Manifest1
-rw-r--r--sys-apps/roccat-tools/roccat-tools-3.9.0.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/roccat-tools/Manifest b/sys-apps/roccat-tools/Manifest
index 586ff77a73b9..45f9bd924d3b 100644
--- a/sys-apps/roccat-tools/Manifest
+++ b/sys-apps/roccat-tools/Manifest
@@ -2,3 +2,4 @@ DIST roccat-tools-3.4.0.tar.bz2 2548969 SHA256 4f0e91b3cfc5be6b2c71d8a1dc77bce27
DIST roccat-tools-3.5.0.tar.bz2 2549533 SHA256 b940702f4005f81fec673e187328a1506d0d77ba27ecac35588b0a0e3313347d SHA512 d86f5a9c76f6c907a6d9353b710b1a24f495b12165ac6750db30a927361d19362fb975ca1fb3ca090cc17942aaa05064b7064d371d6c1ca365c08efce9663f51 WHIRLPOOL 8fbdcf96d675c2a129ff013732a3cb55e2a5426f9ab4df71496d9e3cfeabc2b6d673921ba8b9b24a4278376c0249d9e45b54ff26899de8f2cfc5980d7e37181a
DIST roccat-tools-3.6.1.tar.bz2 3442053 SHA256 2230f2a6da72a1effd513d7bc90456e80b58f8f9fc97134f4ac41559b1bb43af SHA512 a99863fee21700a840572b68dfe859ee6032ee42b527457ac0dadbd696644abba1d7d20ff96e2aa24145af084c632e1f815e31a8eefe12f1edae4a4981b7095a WHIRLPOOL f238c6f8907bbdbace26899228a4578b9103453313b673e265278e6496f8e5c54a60fcb58bfe87cb798ef8bf6f627a2a47f55b964f25cb126f80c7789e75392f
DIST roccat-tools-3.7.0.tar.bz2 3451047 SHA256 fbfd69634e3f504a8a5f43948566eb9c52955416a7e0698218c61e7d586fd1a5 SHA512 d28113c7fdf43bfa91dbd9e7921f20a2ab67214ed902148d3eea8e5eb8c633e4916f27d6e3e9e32357da39961fe71876de656a29a0415e48a20a90b523e51df1 WHIRLPOOL 7317e385b5deb5f805ad312bab3c817fdd4f081632d3ad80eb6747a56d50b45a9da8b4471f6fa1a45cf58424be5a84acecaa55ebd80797210edcf997efccd253
+DIST roccat-tools-3.9.0.tar.bz2 3508796 SHA256 ea90b53cf4707c76a41d0f67711eca91e21ef41be253ab45b113a55ac1f278c1 SHA512 28c7b8c835a92f9fc741e393373388995f7da95971b6eb2432598a17ddd2887505d38a834e3a155331fa4a67e3dc6a559050c9ea69b2729c26648a2ab76266cb WHIRLPOOL 13f08b01ca83d2b5bc035580a87d62264cb9b0644839793049638d2880c34e96941ea55cd923a21ecd3cbe077b4654901dc93046e8f6371bef1a4adf6cbf0977
diff --git a/sys-apps/roccat-tools/roccat-tools-3.9.0.ebuild b/sys-apps/roccat-tools/roccat-tools-3.9.0.ebuild
new file mode 100644
index 000000000000..7aae56bca1e0
--- /dev/null
+++ b/sys-apps/roccat-tools/roccat-tools-3.9.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo cmake-utils gnome2-utils udev user
+
+DESCRIPTION="Utility for advanced configuration of Roccat devices"
+
+HOMEPAGE="http://roccat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_INPUT_DEVICES="
+ input_devices_roccat_arvo
+ input_devices_roccat_isku
+ input_devices_roccat_iskufx
+ input_devices_roccat_kiro
+ input_devices_roccat_kone
+ input_devices_roccat_koneplus
+ input_devices_roccat_konepure
+ input_devices_roccat_konepuremilitary
+ input_devices_roccat_konepureoptical
+ input_devices_roccat_konextd
+ input_devices_roccat_konextdoptical
+ input_devices_roccat_kovaplus
+ input_devices_roccat_kova2016
+ input_devices_roccat_lua
+ input_devices_roccat_nyth
+ input_devices_roccat_pyra
+ input_devices_roccat_ryosmk
+ input_devices_roccat_ryostkl
+ input_devices_roccat_savu
+ input_devices_roccat_tyon
+"
+IUSE="${IUSE_INPUT_DEVICES} lua"
+REQUIRED_USE="
+ lua? ( input_devices_roccat_ryosmk )
+"
+
+RDEPEND="
+ =dev-libs/libgaminggear-0.11*
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ media-libs/libcanberra
+ virtual/libusb:1
+ dev-libs/dbus-glib
+ virtual/libgudev:=
+ lua? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup roccat
+}
+
+src_configure() {
+ local UDEVDIR="$(get_udevdir)"/rules.d
+ local MODELS=${INPUT_DEVICES//roccat_/}
+ mycmakeargs=(
+ -DDEVICES=${MODELS// /;} \
+ -DUDEVDIR="${UDEVDIR/"//"//}"
+ )
+ if use lua ; then
+ mycmakeargs+=( -DWITH_LUA=5.1 )
+ fi
+ cmake-utils_src_configure
+}
+src_install() {
+ cmake-utils_src_install
+ local stat_dir=/var/lib/roccat
+ keepdir $stat_dir
+ fowners root:roccat $stat_dir
+ fperms 2770 $stat_dir
+ readme.gentoo_src_install
+}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+ ewarn
+ ewarn "Starting from version 3.0.0, executables were renamed and now prefixed with 'roccat',"
+ ewarn "so konextdconfig is now roccatkonextdconfig and so on"
+ ewarn "Everything that was ryos is now ryosmk to distinguish it from the ryostkl product range"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}