summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-19 18:31:46 -0700
committerZac Medico <zmedico@gentoo.org>2018-08-19 18:46:42 -0700
commite49cc9f7451bea442690b23bb187af3b382efdf3 (patch)
tree38c191b2ade716c6372ba9a7d468d22b639d508e
parentdev-tex/biber: amd64 stable wrt bug #663754 (diff)
downloadgentoo-e49cc9f7451bea442690b23bb187af3b382efdf3.tar.gz
gentoo-e49cc9f7451bea442690b23bb187af3b382efdf3.tar.bz2
gentoo-e49cc9f7451bea442690b23bb187af3b382efdf3.zip
dev-go/go-tour: version bump to 0_p20180810
Package-Manager: Portage-2.3.47, Repoman-2.3.10
-rw-r--r--dev-go/go-tour/Manifest1
-rw-r--r--dev-go/go-tour/go-tour-0_p20180810.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-go/go-tour/Manifest b/dev-go/go-tour/Manifest
index 37588d9ffd19..59c520eda648 100644
--- a/dev-go/go-tour/Manifest
+++ b/dev-go/go-tour/Manifest
@@ -1 +1,2 @@
DIST go-tour-0_p20160209.tar.gz 275272 BLAKE2B c3d98bf839fc62a43eb7b994a798ab977c19756160930f7ecda39543e8bf4f793ec1eb4f2e3fb202e2bd9b1d8738eed02b40510047fcfe5274ae3c99410dde0a SHA512 bc9131e6173f72ea01c3062454a47a90301ad01bc1ea356ef09b81ad2d887759671ee9700f2c6b47821fc02c49297b8797d732ae0e9b414205e483d30579d2e9
+DIST go-tour-0_p20180810.tar.gz 319048 BLAKE2B 43c4ca53d939cf7590c8e3607e2089974f1b40dc9268ccbf9100e36d258d76a828c5512e662f20d125c07d0a35d48d3004c8f06d6f80a6a1645099d4ca592c57 SHA512 73eb1b7a228d046d572b2c781cdd7b43ef57de982987ab5808cbb2775c34c9805fac3c52fd68edd34ccadec5169ce5d61234eee553daf0b9ef2d2529e2817b44
diff --git a/dev-go/go-tour/go-tour-0_p20180810.ebuild b/dev-go/go-tour/go-tour-0_p20180810.ebuild
new file mode 100644
index 000000000000..b97a2e598afb
--- /dev/null
+++ b/dev-go/go-tour/go-tour-0_p20180810.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="golang.org/x/tour/..."
+
+EGIT_COMMIT="d642b9371986f5bb2152547a0d525a57f634c3ef"
+ARCHIVE_URI="https://github.com/golang/tour/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+inherit golang-vcs-snapshot golang-build
+
+DESCRIPTION="A Tour of Go"
+HOMEPAGE="https://tour.golang.org"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/go-tools:="
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" GOBIN="${S}/bin" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ [[ -x $(find "${T}" -name a.out) ]] || die "a.out not found"
+}
+
+src_install() {
+ GOPATH="${S}:$(get_golibdir_gopath)" GOBIN="${S}/bin" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ exeinto "$(go env GOTOOLDIR)"
+ newexe bin/gotour tour
+ insinto "$(go env GOROOT)"
+ doins -r src
+}
+
+src_test() {
+ GOPATH="${S}:$(get_golibdir_gopath)" GOBIN="${S}/bin" \
+ go test -v -work -x "${EGO_PN}" || die
+}