summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-12 11:11:44 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-12 11:13:19 -0400
commite55a2d9caa18a197b99b0c52328664204c61c3b5 (patch)
treee5abe22efd707b2a015a3dc852481e773e5509e3
parentdev-java/rhino: reduce SLOT back to 1.6. (diff)
downloadgentoo-e55a2d9caa18a197b99b0c52328664204c61c3b5.tar.gz
gentoo-e55a2d9caa18a197b99b0c52328664204c61c3b5.tar.bz2
gentoo-e55a2d9caa18a197b99b0c52328664204c61c3b5.zip
app-editors/curses-hexedit: various fixes
* Update to EAPI=5 * Use subslots w/ncurses dep * Set up a sane CC value by default * Force CONFIG_SHELL as non-bash /bin/sh breaks things Maybe someday there will be a new release w/configure generated by a recent autoconf and we can drop some of these hacks.
-rw-r--r--app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild b/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
index 4ba0ace025b7..0d5772286225 100644
--- a/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
+++ b/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# There's already a "hexedit" package in the tree, so name this one differently
-EAPI="4"
+EAPI="5"
+
+inherit toolchain-funcs
MY_P=${P/curses-}
DESCRIPTION="full screen curses hex editor (with insert/delete support)"
@@ -16,11 +18,14 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="sys-libs/ncurses"
+RDEPEND="sys-libs/ncurses:="
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
src_configure() {
+ # Package has an old configure script.
+ CONFIG_SHELL="/bin/bash"
+ tc-export CC
econf --program-prefix=curses-
}