summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2018-07-22 19:47:12 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2018-07-22 19:51:54 +0300
commite5b12f168dd9f7fbd41510e7ab97079b29bab43f (patch)
tree126c1e05009b0c96a50bd60cb03b9c6e96c191f9
parentsys-apps/baselayout: style change (diff)
downloadgentoo-e5b12f168dd9f7fbd41510e7ab97079b29bab43f.tar.gz
gentoo-e5b12f168dd9f7fbd41510e7ab97079b29bab43f.tar.bz2
gentoo-e5b12f168dd9f7fbd41510e7ab97079b29bab43f.zip
dev-libs/libclsync: remove old
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-libs/libclsync/Manifest1
-rw-r--r--dev-libs/libclsync/libclsync-0.4.1.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-libs/libclsync/Manifest b/dev-libs/libclsync/Manifest
index 80d49e32bcc3..908a4bd9d9e1 100644
--- a/dev-libs/libclsync/Manifest
+++ b/dev-libs/libclsync/Manifest
@@ -1,2 +1 @@
-DIST clsync-0.4.1.tar.gz 253890 BLAKE2B c8aada690635f1cac355a1eaa51f4379688b0005869c5dcd6edccf5ae8e86abddf9ff99ccfcffeb165ccc80f407087a3f0863d1b78279894ff410daf25467740 SHA512 875280f706026d44806b92c22fa58d016136b2792f67a6b7e77f932465081da7a1ebaf22c25e538e4b58bfe04cd1cd5450ecab99c3df53ddd2a0fa966442d444
DIST clsync-0.4.2.tar.gz 256042 BLAKE2B 28474fc66341b93705a502fcff390e3affcd89a9e1eb272dce9b28be709562e09c03e9c300cfeb5371e2e618a2239468a58c46212a39d751fbbfddeaab12bcf6 SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200
diff --git a/dev-libs/libclsync/libclsync-0.4.1.ebuild b/dev-libs/libclsync/libclsync-0.4.1.ebuild
deleted file mode 100644
index ddfca4a6ff90..000000000000
--- a/dev-libs/libclsync/libclsync-0.4.1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_PN=${PN#lib}
-MY_P="${MY_PN}-${PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/xaionaro/${MY_PN}.git"
-else
- SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-inherit autotools
-
-DESCRIPTION="Control and monitoring library for clsync"
-HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="debug extra-debug extra-hardened hardened static-libs"
-REQUIRED_USE="
- extra-debug? ( debug )
- extra-hardened? ( hardened )
-"
-
-DEPEND="virtual/pkgconfig "
-RDEPEND="=app-doc/clsync-docs-0.4*"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- local harden_level=0
- use hardened && harden_level=1
- use extra-hardened && harden_level=2
-
- local debug_level=0
- use debug && debug_level=1
- use extra-debug && debug_level=2
-
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-socket-library \
- --disable-clsync \
- --enable-debug=${debug_level} \
- --enable-paranoid=${harden_level} \
- --without-bsm \
- --without-kqueue \
- --disable-capabilities \
- --disable-cluster \
- --enable-socket \
- --disable-highload-locks \
- --disable-unshare \
- --disable-seccomp \
- --without-libcgroup \
- --without-gio \
- --with-inotify=native \
- --without-mhash
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files
- use static-libs || find "${ED}" -name "*.a" -delete || die "failed to remove static libs"
-
- # docs go into clsync-docs
- rm -rf "${ED}/usr/share/doc" || die
-}
-
-pkg_postinst() {
- einfo "clsync instances you are going to use _must_ be compiled"
- einfo "with control-socket support"
-}