summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-04-23 10:13:25 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-04-23 10:13:25 -0500
commite5d95a206bc74620bb43b47bdc072ea771b07d71 (patch)
treef59baa8d9b1a53837891ddb5eb89eae6937d3537
parentx11-apps/copyq: linguist-tools is a build-time dep only (diff)
downloadgentoo-e5d95a206bc74620bb43b47bdc072ea771b07d71.tar.gz
gentoo-e5d95a206bc74620bb43b47bdc072ea771b07d71.tar.bz2
gentoo-e5d95a206bc74620bb43b47bdc072ea771b07d71.zip
dev-python/docker-py: add version 1.8.0-r1
Due to bug #580388, I've removed python2_7 support from docker-py. This shouldn't be a problem. This removes the conflict due to py2-ipaddress and makes the question of which package to keep moot. With py2-ipaddress no longer required by anything in the tree I will be running it through the last-rites process. Package-Manager: portage-2.2.28
-rw-r--r--dev-python/docker-py/docker-py-1.8.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/docker-py/docker-py-1.8.0-r1.ebuild b/dev-python/docker-py/docker-py-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..4f2348c35f6b
--- /dev/null
+++ b/dev-python/docker-py/docker-py-1.8.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
+ test? (
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ ~dev-python/pytest-2.7.2[${PYTHON_USEDEP}]
+ ~dev-python/pytest-cov-2.1.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ if use doc; then
+ mkdocs build -d 'mkdocs_site' || die "docs failed to build"
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ | die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( mkdocs_site/. )
+
+ distutils-r1_python_install_all
+}