summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-19 01:51:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-19 07:43:52 +0100
commite61257df8c74213cdb9cb10594d605cae71c4899 (patch)
treed5b4d1cd15dffcf8ed898f636bbc3650ef8c0f63
parentdev-ruby/rack-protection: add 2.0.1 (diff)
downloadgentoo-e61257df8c74213cdb9cb10594d605cae71c4899.tar.gz
gentoo-e61257df8c74213cdb9cb10594d605cae71c4899.tar.bz2
gentoo-e61257df8c74213cdb9cb10594d605cae71c4899.zip
media-video/vlc: Revert drop USE=linsys, merge with USE=zvbi
Let's keep the hardware support independent, as it can be used without USE=zvbi which selects between two different vlc modules.
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild11
-rw-r--r--media-video/vlc/vlc-9999.ebuild13
2 files changed, 13 insertions, 11 deletions
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index b20113567056..74239039af50 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -30,9 +30,9 @@ LICENSE="LGPL-2.1 GPL-2"
SLOT="0/5-9" # vlc - vlccore
IUSE="a52 aalib alsa altivec aom archive bidi bluray cddb chromaprint chromecast dbus
- dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth
- fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate libass libav
- libcaca libnotify +libsamplerate libtar libtiger lirc live lua macosx-notifications
+ dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth fontconfig
+ +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate libass libav libcaca
+ libnotify +libsamplerate libtar libtiger linsys lirc live lua macosx-notifications
macosx-qtkit matroska modplug mp3 mpeg mtp musepack ncurses neon nfs ogg omxil opencv
optimisememory opus png postproc projectm pulseaudio +qt5 rdp rtsp run-as-root
samba schroedinger sdl-image sftp shout sid skins speex ssl svg taglib theora tremor
@@ -119,6 +119,7 @@ RDEPEND="
libsamplerate? ( media-libs/libsamplerate:0 )
libtar? ( dev-libs/libtar:0 )
libtiger? ( media-libs/libtiger:0 )
+ linsys? ( media-libs/zvbi )
lirc? ( app-misc/lirc:0 )
live? ( media-plugins/live:0 )
lua? ( >=dev-lang/lua-5.1:0 )
@@ -206,7 +207,7 @@ RDEPEND="
x265? ( media-libs/x265:0= )
xml? ( dev-libs/libxml2:2 )
zeroconf? ( net-dns/avahi:0[dbus] )
- zvbi? ( media-libs/zvbi:0 )
+ zvbi? ( media-libs/zvbi )
"
DEPEND="${RDEPEND}
>=sys-devel/gettext-0.19.8:*
@@ -315,6 +316,7 @@ src_configure() {
$(use_enable libsamplerate samplerate)
$(use_enable libtar)
$(use_enable libtiger tiger)
+ $(use_enable linsys)
$(use_enable lirc)
$(use_enable live live555)
$(use_enable lua)
@@ -376,7 +378,6 @@ src_configure() {
$(use_enable xml libxml2)
$(use_enable zeroconf avahi)
$(use_enable zvbi)
- $(use_enable zvbi linsys)
$(use_enable !zvbi telx)
--disable-asdcp
--disable-coverage
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index bfe872bbf4b9..5ba1166a4d55 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -30,14 +30,14 @@ LICENSE="LGPL-2.1 GPL-2"
SLOT="0/5-9" # vlc - vlccore
IUSE="a52 aalib alsa altivec aom archive bidi bluray cddb chromaprint chromecast dbus
- dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth
- fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate libass libav
- libcaca libnotify +libsamplerate libtar libtiger lirc live lua macosx-notifications
+ dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth fontconfig
+ +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate libass libav libcaca
+ libnotify +libsamplerate libtar libtiger linsys lirc live lua macosx-notifications
macosx-qtkit matroska modplug mp3 mpeg mtp musepack ncurses neon nfs ogg omxil opencv
optimisememory opus png postproc projectm pulseaudio +qt5 rdp rtsp run-as-root
samba schroedinger sdl-image sftp shout sid skins speex ssl svg taglib theora tremor
truetype twolame udev upnp vaapi v4l vcd vdpau vnc vorbis vpx wayland wma-fixed +X
- x264 x265 +xcb xml zeroconf zvbi cpu_flags_x86_mmx cpu_flags_x86_sse
+ x264 x265 xml zeroconf zvbi cpu_flags_x86_mmx cpu_flags_x86_sse
"
REQUIRED_USE="
aalib? ( X )
@@ -119,6 +119,7 @@ RDEPEND="
libsamplerate? ( media-libs/libsamplerate:0 )
libtar? ( dev-libs/libtar:0 )
libtiger? ( media-libs/libtiger:0 )
+ linsys? ( media-libs/zvbi )
lirc? ( app-misc/lirc:0 )
live? ( media-plugins/live:0 )
lua? ( >=dev-lang/lua-5.1:0 )
@@ -206,7 +207,7 @@ RDEPEND="
x265? ( media-libs/x265:0= )
xml? ( dev-libs/libxml2:2 )
zeroconf? ( net-dns/avahi:0[dbus] )
- zvbi? ( media-libs/zvbi:0 )
+ zvbi? ( media-libs/zvbi )
"
DEPEND="${RDEPEND}
>=sys-devel/gettext-0.19.8:*
@@ -315,6 +316,7 @@ src_configure() {
$(use_enable libsamplerate samplerate)
$(use_enable libtar)
$(use_enable libtiger tiger)
+ $(use_enable linsys)
$(use_enable lirc)
$(use_enable live live555)
$(use_enable lua)
@@ -376,7 +378,6 @@ src_configure() {
$(use_enable xml libxml2)
$(use_enable zeroconf avahi)
$(use_enable zvbi)
- $(use_enable zvbi linsys)
$(use_enable !zvbi telx)
--disable-asdcp
--disable-coverage