summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-22 15:49:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-22 19:02:25 +0200
commite6160918da815a3c3419a20a78ec91c305c6c656 (patch)
treeb86004947d35964eee1d5a13c98cba1e18ab0930
parentwww-client/chromium: stable channel bump (86.0.4240.111) (diff)
downloadgentoo-e6160918da815a3c3419a20a78ec91c305c6c656.tar.gz
gentoo-e6160918da815a3c3419a20a78ec91c305c6c656.tar.bz2
gentoo-e6160918da815a3c3419a20a78ec91c305c6c656.zip
media-libs/xvid: bump to 1.3.7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--media-libs/xvid/Manifest1
-rw-r--r--media-libs/xvid/xvid-1.3.7.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/xvid/Manifest b/media-libs/xvid/Manifest
index fc856890cf73..fb8109e94b97 100644
--- a/media-libs/xvid/Manifest
+++ b/media-libs/xvid/Manifest
@@ -1 +1,2 @@
DIST xvidcore-1.3.5.tar.bz2 698846 BLAKE2B c65c90a2a51d993af65becd760364b495ca1714f888c640b577ee3cb509afc5dbe56d1f536aa710a5322106ca65bed4ad162ad97440e9c14deeabbcbe00984b5 SHA512 3297243400ce9ed2d0083559ee15fdfa422e585114c4e92c72fe702f43fea4af9fe4e9e794630959c220222379fa329452c4163a395f4ba1998c9be03a2e9441
+DIST xvidcore-1.3.7.tar.bz2 698615 BLAKE2B 19bea63226c2223e74e5202d3b671c5b292c03ce5de240df7d8ce34101de4036b28fad516b2a56712a099819b905e68922fa83a01fbe4f200dc880ca56c10a96 SHA512 e2b22e7a7e103af7adcc999d95484f991a0a33df02b912fe042b2e23d2af07381c737d23158dbf0fad770ee680572f86fbe04ab2ef33c81e2e0180ead2acc8ed
diff --git a/media-libs/xvid/xvid-1.3.7.ebuild b/media-libs/xvid/xvid-1.3.7.ebuild
new file mode 100644
index 000000000000..bfd41066754c
--- /dev/null
+++ b/media-libs/xvid/xvid-1.3.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN}core"
+MY_P="${MY_PN}-${PV}"
+inherit flag-o-matic multilib-minimal
+
+DESCRIPTION="High performance/quality MPEG-4 video de-/encoding solution"
+HOMEPAGE="https://www.xvid.org/"
+SRC_URI="https://downloads.xvid.com/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="elibc_FreeBSD examples pic +threads"
+
+NASM=">=dev-lang/nasm-2"
+YASM=">=dev-lang/yasm-1"
+
+BDEPEND="sys-apps/grep"
+DEPEND="amd64? ( || ( ${YASM} ${NASM} ) )
+ x86? ( || ( ${YASM} ${NASM} ) )
+ x86-macos? ( ${NASM} )
+ x64-macos? ( ${NASM} )"
+
+S="${WORKDIR}/${MY_PN}/build/generic"
+
+src_prepare() {
+ default
+
+ # make build verbose
+ sed \
+ -e 's/@$(CC)/$(CC)/' \
+ -e 's/@$(AS)/$(AS)/' \
+ -e 's/@$(RM)/$(RM)/' \
+ -e 's/@$(INSTALL)/$(INSTALL)/' \
+ -e 's/@cd/cd/' \
+ -e '/\$(libdir)\/\$(STATIC_LIB)/d' \
+ -e 's/\$(BUILD_DIR)\/\$(STATIC_LIB)//g' \
+ -e 's/info \$(STATIC_LIB)/info/g' \
+ -i Makefile || die
+ # Since only the build system is in $S, this will only copy it but not the
+ # entire sources.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use sparc && append-cflags -mno-vis #357149
+ use elibc_FreeBSD && export ac_cv_prog_ac_yasm=no #477736
+
+ local myconf=( $(use_enable threads pthread) )
+ if use pic || [[ ${ABI} == "x32" ]] ; then #421841
+ myconf+=( --disable-assembly )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc "${S}"/../../{AUTHORS,ChangeLog*,CodingStyle,README,TODO}
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r "${S}"/../../examples
+ fi
+}