summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2017-01-19 03:24:51 +0300
committerGöktürk Yüksek <gokturk@gentoo.org>2017-01-26 03:25:50 -0500
commite64a786b623af3a08ee3f1a5bf8e654e4fdfa882 (patch)
tree5483f94b8b7f6b7530ee84d2511c3a8292e300e7
parentros-meta/rosbridge_suite: Bump to 0.7.17. (diff)
downloadgentoo-e64a786b623af3a08ee3f1a5bf8e654e4fdfa882.tar.gz
gentoo-e64a786b623af3a08ee3f1a5bf8e654e4fdfa882.tar.bz2
gentoo-e64a786b623af3a08ee3f1a5bf8e654e4fdfa882.zip
app-text/po4a: version bump to 0.47
Gentoo-Bug: 550210
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/po4a-0.47.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
index 2a58986d8c5d..32a81eb49659 100644
--- a/app-text/po4a/Manifest
+++ b/app-text/po4a/Manifest
@@ -1 +1,2 @@
DIST po4a_0.45.orig.tar.gz 2208959 SHA256 f5f47db85b48893d87d921152c96082233975bd0e0a9ee14f58c07d7dff81678 SHA512 e67334b7a45d3c23b7226077e01e12b3c4f1202531596f02851b6a9e7249b2b8a0c37f37ebbaf591753f041a4c6ce42c062b4822e91ac75884dcd0994c27323f WHIRLPOOL 404bb45412fff4cec13304490e5f74ee4a4573d3c755491816cfe501c3e83dbdb58ae3c799516fe21c692c9de6fbc2dd5a261c8039eca2e2777365b27ac358cd
+DIST po4a_0.47.orig.tar.gz 2389750 SHA256 5010e1b7df1115cbd475f46587fc05fefc97301f9bba0c2f15106005ca017507 SHA512 9c459a9795977a39aacc09cfb6ddbdc7dd2174e22896fa7bde90510a43ea833054aef558f7ca798991addc052a2c7f91ee11e5d49658a5c80a9ecb9c135ff97a WHIRLPOOL f6b52ffd39ebfc3ec71d5719fc7e01260acb4d4525d63209c69cc73aa5d18dec6f06e476d911591c8b6a89ab4d73747221320ae578835f2a2c1fb84c665480ab
diff --git a/app-text/po4a/po4a-0.47.ebuild b/app-text/po4a/po4a-0.47.ebuild
new file mode 100644
index 000000000000..a1bafa0635e9
--- /dev/null
+++ b/app-text/po4a/po4a-0.47.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PLOCALES="af ca cs da de eo es et eu fr hr id it ja kn ko nb nl pl pt_BR pt ru sl sv uk vi zh_CN zh_HK"
+PLOCALES_BACKUP="en"
+
+# Needed because this package also installs to vendor_perl
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit perl-module l10n
+
+DESCRIPTION="Tools for helping translation of documentation"
+HOMEPAGE="http://po4a.alioth.debian.org"
+SRC_URI="mirror://debian/pool/main/p/po4a/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-perl/SGMLSpm
+ >=sys-devel/gettext-0.13
+ app-text/openjade
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ test? ( app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ virtual/tex-base )"
+
+# Running tests in parallel fails
+DIST_TEST="do"
+
+src_prepare() {
+ # Check against locale files in ${S}/pod/bin for mismatches
+ # with languages listed in PLOCALES
+ local locales_path="$S/po/bin"
+ l10n_find_plocales_changes "$locales_path" "" ".po"
+
+ # Get rid of disabled locales
+ my_get_disabled_locales() {
+ PERL_RM_FILES=( "${PERL_RM_FILES[@]}" "po/bin/${1}.po" "po/pod/${1}.po" )
+ }
+
+ l10n_for_each_disabled_locale_do my_get_disabled_locales
+
+ einfo "Your LINGUAS lists the following languages: $LINGUAS"
+
+ perl-module_src_prepare
+}