summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-20 19:56:08 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-20 20:51:04 +0200
commite6cef0093720f4e9ebbe835afc03ba3e364ef892 (patch)
treec72924d73dc3ad70ad05b3406ae0f4d885396415
parentmedia-gfx/yafaray: Drop old (diff)
downloadgentoo-e6cef0093720f4e9ebbe835afc03ba3e364ef892.tar.gz
gentoo-e6cef0093720f4e9ebbe835afc03ba3e364ef892.tar.bz2
gentoo-e6cef0093720f4e9ebbe835afc03ba3e364ef892.zip
media-libs/libsfml: Bump to 2.5.1
Closes: https://bugs.gentoo.org/663652 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--media-libs/libsfml/Manifest1
-rw-r--r--media-libs/libsfml/libsfml-2.5.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-libs/libsfml/Manifest b/media-libs/libsfml/Manifest
index e387c9847b8d..ee28d09e5fc8 100644
--- a/media-libs/libsfml/Manifest
+++ b/media-libs/libsfml/Manifest
@@ -1,2 +1,3 @@
DIST libsfml-2.4.2.tar.gz 24576150 BLAKE2B 05d1c06cb360aae6ec8a53225666119168075ab61dd87fe86a105f2c104d21b5897c4b35e66f5c0dae7193697437d168a963c018e3d39bd7b8b6bed957a63d94 SHA512 8acfdf320939c953a9a3413398f82d02d68a56a337f1366c2677c14ce032baa8ba059113ac3c91bb6e6fc22eef119369a265be7ef6894526e6a97a01f37e1972
DIST libsfml-2.5.0.tar.gz 22864874 BLAKE2B 69f3a98e6db2cfbd6208167cd9cfaf92d980a7da878b026a12db646cc3638edd237ce61c123934c8169f7bc204cca64618aec89c51e7667aef03b6c72ee84a63 SHA512 94306dcbed7d68bb7e226cd91e25950a07bcf393988c4bb79f9de3555c18c78cae4573e911235f712e711a7c02a614bf370df32b8d85240d2f08142327e05076
+DIST libsfml-2.5.1.tar.gz 22868556 BLAKE2B b6c70b75a778ffeb141438153fb1e5693c3e92e277919b8f8befe98f55dfd519a67c86504bb5656961b947fcf60758b16a18d5a4ae7585c7c5256f327529ae31 SHA512 7aed2fc29d1da98e6c4d598d5c86cf536cb4eb5c2079cdc23bb8e502288833c052579dadbe0ce13ad6461792d959bf6d9660229f54c54cf90a541c88c6b03d59
diff --git a/media-libs/libsfml/libsfml-2.5.1.ebuild b/media-libs/libsfml/libsfml-2.5.1.ebuild
new file mode 100644
index 000000000000..d7b28cb87d90
--- /dev/null
+++ b/media-libs/libsfml/libsfml-2.5.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils eapi7-ver
+
+MY_P="SFML-${PV}"
+
+DESCRIPTION="Simple and Fast Multimedia Library (SFML)"
+HOMEPAGE="http://www.sfml-dev.org/ https://github.com/SFML/SFML"
+SRC_URI="https://github.com/SFML/SFML/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="
+ media-libs/flac
+ media-libs/freetype:2
+ media-libs/libpng:0=
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ virtual/jpeg:0
+ kernel_linux? ( virtual/libudev:0 )
+ virtual/opengl
+ !kernel_Winnt? (
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( changelog.md readme.md )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i "s:DESTINATION .*:DESTINATION /usr/share/doc/${PF}:" \
+ doc/CMakeLists.txt || die
+
+ find examples -name CMakeLists.txt -delete || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSFML_BUILD_DOC=$(usex doc)
+ -DSFML_INSTALL_PKGCONFIG_FILES=TRUE
+ )
+
+ if use kernel_Winnt; then
+ mycmakeargs+=( -DSFML_USE_SYSTEM_DEPS=TRUE )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ insinto /usr/share/cmake/Modules
+ doins cmake/SFMLConfig.cmake.in
+ doins cmake/SFMLConfigDependencies.cmake.in
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}