summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-27 11:08:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-27 11:26:01 +0200
commite6cf2224cdc060339bc12a99124424b6e64705ad (patch)
tree1b535382c1a4ce2d6a7a28f7294e8a8da42c6b8f
parentdev-ros/dwa_local_planner: Bump to 1.16.0. (diff)
downloadgentoo-e6cf2224cdc060339bc12a99124424b6e64705ad.tar.gz
gentoo-e6cf2224cdc060339bc12a99124424b6e64705ad.tar.bz2
gentoo-e6cf2224cdc060339bc12a99124424b6e64705ad.zip
dev-ros/fake_localization: Bump to 1.16.0.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-ros/fake_localization/Manifest1
-rw-r--r--dev-ros/fake_localization/fake_localization-1.16.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/fake_localization/Manifest b/dev-ros/fake_localization/Manifest
index 1ff34582242f..e2d2b2ee457b 100644
--- a/dev-ros/fake_localization/Manifest
+++ b/dev-ros/fake_localization/Manifest
@@ -1 +1,2 @@
DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
+DIST navigation-1.16.0.tar.gz 336708 BLAKE2B 74fdc7c3afb00bfbded011678c90b22cc95fe45b126c9a8a4bb9a80f8676ed0ade32e02ad77ec643f167d9719e71347750b6f7993f61cf743fc018d1412436d6 SHA512 ee6336627c2e095ef089534c19b7258f394858a6c04ad49b3aa6e1d0acca67c245c2743f04752be137864dba216c3aa38e34c3e40e3db7839308be3adbc808d6
diff --git a/dev-ros/fake_localization/fake_localization-1.16.0.ebuild b/dev-ros/fake_localization/fake_localization-1.16.0.ebuild
new file mode 100644
index 000000000000..0c7895911491
--- /dev/null
+++ b/dev-ros/fake_localization/fake_localization-1.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="A ROS node that simply forwards odometry information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/angles
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/message_filters
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"