summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-15 09:48:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-15 09:49:14 +0000
commite785b425ed9fce88ec735a046d8d62d3f8d53be6 (patch)
treec94991a110d647a4583707f74f21134101c19b5c
parentarch/riscv/package.use.mask: mask gdb[xxhash], not keywords yet (diff)
downloadgentoo-e785b425ed9fce88ec735a046d8d62d3f8d53be6.tar.gz
gentoo-e785b425ed9fce88ec735a046d8d62d3f8d53be6.tar.bz2
gentoo-e785b425ed9fce88ec735a046d8d62d3f8d53be6.zip
sys-devel/gdb: add USE=xxhash, bug #709690
xxhash is an optional dependency to speed up internal hashing. Reported-by: Georgy Yakovlev Closes: https://bugs.gentoo.org/709690 Bug: https://bugs.gentoo.org/709696 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/gdb/gdb-9.1.ebuild8
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild8
-rw-r--r--sys-devel/gdb/metadata.xml1
3 files changed, 13 insertions, 4 deletions
diff --git a/sys-devel/gdb/gdb-9.1.ebuild b/sys-devel/gdb/gdb-9.1.ebuild
index fa5deb598106..c27518d0c97d 100644
--- a/sys-devel/gdb/gdb-9.1.ebuild
+++ b/sys-devel/gdb/gdb-9.1.ebuild
@@ -46,7 +46,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml"
+IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
@@ -65,7 +65,7 @@ RDEPEND="
client? (
dev-libs/mpfr:0=
>=sys-libs/ncurses-5.2-r2:0=
- sys-libs/readline:0=
+ >=sys-libs/readline-7:0=
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
xml? ( dev-libs/expat )
@@ -74,6 +74,9 @@ RDEPEND="
source-highlight? (
dev-util/source-highlight
)
+ xxhash? (
+ dev-libs/xxhash
+ )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -171,6 +174,7 @@ src_configure() {
$(use_enable source-highlight)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")
+ $(use_with xxhash)
)
fi
if use sparc-solaris || use x86-solaris ; then
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 0917eed36ce3..06bc04042454 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -46,7 +46,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml"
+IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
@@ -65,7 +65,7 @@ RDEPEND="
client? (
dev-libs/mpfr:0=
>=sys-libs/ncurses-5.2-r2:0=
- sys-libs/readline:0=
+ >=sys-libs/readline-7:0=
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
xml? ( dev-libs/expat )
@@ -74,6 +74,9 @@ RDEPEND="
source-highlight? (
dev-util/source-highlight
)
+ xxhash? (
+ dev-libs/xxhash
+ )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -169,6 +172,7 @@ src_configure() {
$(use_enable source-highlight)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")
+ $(use_with xxhash)
)
fi
if use sparc-solaris || use x86-solaris ; then
diff --git a/sys-devel/gdb/metadata.xml b/sys-devel/gdb/metadata.xml
index 4940999342f2..c0ef0493f2a0 100644
--- a/sys-devel/gdb/metadata.xml
+++ b/sys-devel/gdb/metadata.xml
@@ -13,6 +13,7 @@
<flag name="server">Install the "gdbserver" program (useful for embedded/remote targets)</flag>
<flag name="source-highlight">Enable listing highlighting via <pkg>dev-util/source-highlight</pkg></flag>
<flag name="xml">Support parsing XML data files needed (at least) for cpu features, memory maps, and syscall tracing</flag>
+ <flag name="xxhash">Use <pkg>dev-libs/xxhash</pkg> to speed up internal hashing.</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:gnu:gdb</remote-id>