summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-11-07 10:33:24 -0800
committerZac Medico <zmedico@gentoo.org>2016-11-07 10:34:04 -0800
commite7a055685d2177b289a8f24d578ff7946c93409f (patch)
tree320b6e773b54e48020e3a87328f6d42e9f387534
parentmedia-gfx/hugin: Let eclass delete superfluous modules (diff)
downloadgentoo-e7a055685d2177b289a8f24d578ff7946c93409f.tar.gz
gentoo-e7a055685d2177b289a8f24d578ff7946c93409f.tar.bz2
gentoo-e7a055685d2177b289a8f24d578ff7946c93409f.zip
dev-python/pycares: version bump to 2.1.1
Package-Manager: portage-2.3.2
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-2.1.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index b52a9b1cdc4c..923f0b8c0211 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1 +1,2 @@
DIST pycares-2.1.0.tar.gz 226838 SHA256 449ad785ecb594ae063c0c86537ef97513385117a2eb172f747ad2a29221e898 SHA512 189851a9488828eb41bd6adbefd14022ae8470bde98c1d1c21d67992acdf721e6a61c3d8d8b4f85fb420e1e0900c54e53893586d6f80cc822371260fc17e55c4 WHIRLPOOL 3c3274e122fcea0edee02e1d1719c5dfbf6d437860d2962da0c18e8e56314df149f5c40e1847f7b9ad58c10a594943419453f594017e8508d7d7acf6197c6d22
+DIST pycares-2.1.1.tar.gz 226787 SHA256 17f06ecc2f7f5950922891dfe179a14382e34d620919c17f18957c6cd319ef43 SHA512 c3524a49f5abe4222c9371ca269918eecf30a77bd52258187766833b4663be861678ebe6f1cb2f50e824d36e75938162d5528abd5445c477f23fb85c24572403 WHIRLPOOL 563b28c8d3ff7ada39d9c270087bfbaab87c8c85882db68fe947feee22fe910db2b3b03bb328224fa9dd57ca4b24587d513625d46811b8ba0ce065ea951025b3
diff --git a/dev-python/pycares/pycares-2.1.1.ebuild b/dev-python/pycares/pycares-2.1.1.ebuild
new file mode 100644
index 000000000000..5cc5d522a015
--- /dev/null
+++ b/dev-python/pycares/pycares-2.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+# uses bundled/patched c-ares
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON:-python}" tests/tests.py || die
+}