summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 12:28:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 13:03:07 +0100
commite7b2e3e63860442bcffaadbbd1037995bba244ec (patch)
treead0d207e7d9ec52fad1ff3ec14809b61a5f59e0e
parentapp-cdr/gaffitter: Port to EAPI 6 (diff)
downloadgentoo-e7b2e3e63860442bcffaadbbd1037995bba244ec.tar.gz
gentoo-e7b2e3e63860442bcffaadbbd1037995bba244ec.tar.bz2
gentoo-e7b2e3e63860442bcffaadbbd1037995bba244ec.zip
app-cdr/daa2iso: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-cdr/daa2iso/daa2iso-0.1.7e.ebuild16
-rw-r--r--app-cdr/daa2iso/files/daa2iso-0.1.7e-buildsystem.patch17
2 files changed, 15 insertions, 18 deletions
diff --git a/app-cdr/daa2iso/daa2iso-0.1.7e.ebuild b/app-cdr/daa2iso/daa2iso-0.1.7e.ebuild
index e924db28243b..1f49851b0089 100644
--- a/app-cdr/daa2iso/daa2iso-0.1.7e.ebuild
+++ b/app-cdr/daa2iso/daa2iso-0.1.7e.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-inherit base toolchain-funcs
+EAPI=6
+
+inherit toolchain-funcs
DESCRIPTION="Program for converting the DAA and GBI files to ISO"
HOMEPAGE="http://aluigi.org/mytoolz.htm"
@@ -16,13 +17,14 @@ IUSE=""
DEPEND="app-arch/unzip"
RDEPEND=""
-S="${WORKDIR}/src"
+S=${WORKDIR}/src
PATCHES=( "${FILESDIR}"/${P}-buildsystem.patch )
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+src_configure() {
+ tc-export CC
}
src_install() {
- emake PREFIX="${D}"/usr install || die "emake install failed"
+ emake PREFIX="${ED%/}"/usr install
+ einstalldocs
}
diff --git a/app-cdr/daa2iso/files/daa2iso-0.1.7e-buildsystem.patch b/app-cdr/daa2iso/files/daa2iso-0.1.7e-buildsystem.patch
index b084d7bb7236..5163d8bfa5d4 100644
--- a/app-cdr/daa2iso/files/daa2iso-0.1.7e-buildsystem.patch
+++ b/app-cdr/daa2iso/files/daa2iso-0.1.7e-buildsystem.patch
@@ -1,22 +1,17 @@
-Index: work/src/Makefile
-===================================================================
---- work.orig/src/Makefile
-+++ work/src/Makefile
-@@ -1,13 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,13 +1,9 @@
EXE = daa2iso
-CFLAGS += -O2 -s
--PREFIX = /usr/local
-+PREFIX = /usr/
+ PREFIX = /usr/local
BINDIR = $(PREFIX)/bin
SRC = $(EXE).c
- all:
+-all:
- $(CC) $(CFLAGS) -c LzmaDec.c
- $(CC) $(CFLAGS) -c tinflate.c
- $(CC) $(SRC) $(CFLAGS) -o $(EXE) LzmaDec.o tinflate.o
-+ $(CC) $(CFLAGS) $(LDFLAGS) -c LzmaDec.c
-+ $(CC) $(CFLAGS) $(LDFLAGS) -c tinflate.c
-+ $(CC) $(SRC) $(CFLAGS) $(LDFLAGS) -o $(EXE) LzmaDec.o tinflate.o
++$(EXE): LzmaDec.o tinflate.o
install:
install -m 755 -d $(BINDIR)