summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-25 11:45:39 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-25 11:51:50 -0700
commite7fc9c1f26d2b39a3cd612f4451fbb4201174465 (patch)
tree763e3352c6a29249354686965320757b368bcf50
parentnet-libs/gupnp: Version bump to 1.2.6 (diff)
downloadgentoo-e7fc9c1f26d2b39a3cd612f4451fbb4201174465.tar.gz
gentoo-e7fc9c1f26d2b39a3cd612f4451fbb4201174465.tar.bz2
gentoo-e7fc9c1f26d2b39a3cd612f4451fbb4201174465.zip
media-gfx/shotwell: Version bump to 0.30.12
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.30.12.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 1925eb89c71a..f76b78b73a72 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1 +1,2 @@
DIST shotwell-0.30.11.tar.xz 6499416 BLAKE2B 8b63b2ff64ae41560221d9bcca2c88d0dff8c40416278d3344dbdbf50e4352e999e3ae52ea9fbcc871d5023ffeeb6ee954ee91a2d7eddc1a8f1df45dc4e12cf8 SHA512 71a057aa1ae2b432f385e174429e29f46ca29055aa6003b6017f3da54551027536c70e9f8ca605719e8e008233bdb6f17981462a54495d91e94aebdbe5718c9f
+DIST shotwell-0.30.12.tar.xz 6519996 BLAKE2B 7417f1bf0057b4974b45be675b177f6fba232d60d56c3d98cc6d5a7a95a31281add5190a04eab965739759aa7d826515996f2fd62350352a54ebf969dc732d95 SHA512 3274f15969be7f75ad2fa44e78773b76e11ee6cf8d4990c7f658fa8ce7e84a8fa5f06542fbab4b585c70e41c097c7b07ba702540102e4d0dfca8e927e00180cf
diff --git a/media-gfx/shotwell/shotwell-0.30.12.ebuild b/media-gfx/shotwell/shotwell-0.30.12.ebuild
new file mode 100644
index 000000000000..3397e5e68673
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.30.12.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8
+ >=net-libs/webkit-gtk-2.26:4
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.10.4
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16:=
+ dev-libs/libgdata
+ >=app-crypt/gcr-3:=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-2.3.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:2.4[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity-support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ -Dextra-plugins=true
+ #trace
+ #measure
+ -Ddupe-detection=true
+ $(meson_use udev)
+ -Dinstall-apport-hook=false
+ $(meson_use opencv face-detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}