summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2015-08-18 17:59:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2015-08-18 17:59:25 +0300
commite8613404934449f886ec5cb04b2a8a5547c892d7 (patch)
treeb502fa36fbf4dd57a2da2a54f5171e091260098b
parentdev-java/commons-configuration: stable for all wrt bug #557976 (diff)
downloadgentoo-e8613404934449f886ec5cb04b2a8a5547c892d7.tar.gz
gentoo-e8613404934449f886ec5cb04b2a8a5547c892d7.tar.bz2
gentoo-e8613404934449f886ec5cb04b2a8a5547c892d7.zip
dev-java/commons-configuration: Drop old
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild71
-rw-r--r--dev-java/commons-configuration/commons-configuration-1.6.ebuild71
2 files changed, 0 insertions, 142 deletions
diff --git a/dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild b/dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild
deleted file mode 100644
index 00ab9c1d6a7b..000000000000
--- a/dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=1
-
-JAVA_PKG_IUSE="doc source"
-
-inherit eutils java-pkg-2 java-ant-2
-
-DESCRIPTION="Generic interface for reading configuration data from a variety of sources"
-HOMEPAGE="http://commons.apache.org/configuration/"
-SRC_URI="mirror://apache/commons/configuration/source/${P}-src.tar.gz"
-
-# it needs functionality from ant-core, although not providing an ant task
-# the functionality is apparently needed only for 1.4 jdk
-# but I don't feel like adding virtual for this
-COMMON_DEPENDS="
- >=dev-java/commons-beanutils-1.7.0:1.7
- >=dev-java/commons-codec-1.3:0
- >=dev-java/commons-collections-3.1:0
- >=dev-java/commons-digester-1.8:0
- >=dev-java/commons-jxpath-1.2:0
- >=dev-java/commons-lang-2.4:2.1
- >=dev-java/commons-logging-1.1.1:0
- java-virtuals/servlet-api:2.5
- dev-java/ant-core:0"
-
-DEPEND=">=virtual/jdk-1.6
- ${COMMON_DEPENDS}"
-RDEPEND=">=virtual/jre-1.6
- ${COMMON_DEPENDS}"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${P}-src"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Tweak build classpath and don't automatically run tests
- epatch "${FILESDIR}/${P}-gentoo.patch"
-
- java-ant_rewrite-classpath
-}
-
-EANT_GENTOO_CLASSPATH="
- commons-beanutils:1.7
- commons-codec
- commons-collections
- commons-digester
- commons-jxpath
- commons-lang:2.1
- commons-logging
- servlet-api:2.5
- ant-core"
-
-# Would need mockobjects with j2ee support which we don't have
-# Check overlay for ebuild with test support
-RESTRICT="test"
-
-src_install() {
- java-pkg_newjar target/${P}.jar
- dodoc RELEASE-NOTES.txt || die
- use doc && java-pkg_dohtml -r dist/docs/api
- use source && java-pkg_dosrc src/java/*
-}
diff --git a/dev-java/commons-configuration/commons-configuration-1.6.ebuild b/dev-java/commons-configuration/commons-configuration-1.6.ebuild
deleted file mode 100644
index 91b467e6a118..000000000000
--- a/dev-java/commons-configuration/commons-configuration-1.6.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=1
-
-JAVA_PKG_IUSE="doc source"
-
-inherit eutils java-pkg-2 java-ant-2
-
-DESCRIPTION="Generic interface for reading configuration data from a variety of sources"
-HOMEPAGE="http://commons.apache.org/configuration/"
-SRC_URI="mirror://apache/commons/configuration/source/${P}-src.tar.gz"
-
-# it needs functionality from ant-core, although not providing an ant task
-# the functionality is apparently needed only for 1.4 jdk
-# but I don't feel like adding virtual for this
-COMMON_DEPENDS="
- >=dev-java/commons-beanutils-1.7.0:1.7
- >=dev-java/commons-codec-1.3:0
- >=dev-java/commons-collections-3.1:0
- >=dev-java/commons-digester-1.8:0
- >=dev-java/commons-jxpath-1.2:0
- >=dev-java/commons-lang-2.4:2.1
- >=dev-java/commons-logging-1.1.1:0
- dev-java/servletapi:2.4
- dev-java/ant-core:0"
-
-DEPEND=">=virtual/jdk-1.4
- ${COMMON_DEPENDS}"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEPENDS}"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
-
-S="${WORKDIR}/${P}-src"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Tweak build classpath and don't automatically run tests
- epatch "${FILESDIR}/${P}-gentoo.patch"
-
- java-ant_rewrite-classpath
-}
-
-EANT_GENTOO_CLASSPATH="
- commons-beanutils-1.7
- commons-codec
- commons-collections
- commons-digester
- commons-jxpath
- commons-lang-2.1
- commons-logging
- servletapi-2.4
- ant-core"
-
-# Would need mockobjects with j2ee support which we don't have
-# Check overlay for ebuild with test support
-RESTRICT="test"
-
-src_install() {
- java-pkg_newjar target/${P}.jar
- dodoc RELEASE-NOTES.txt || die
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/java/*
-}