summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-04-11 10:06:42 +0200
committerFabian Groffen <grobian@gentoo.org>2019-04-11 10:06:58 +0200
commite90abf4be37ca322749be5f0f088f6c07ee20b82 (patch)
treea2afc810353d4a1d2e1111d9e6aea92aff1a9407
parentdev-ruby/bson: cleanup (diff)
downloadgentoo-e90abf4be37ca322749be5f0f088f6c07ee20b82.tar.gz
gentoo-e90abf4be37ca322749be5f0f088f6c07ee20b82.tar.bz2
gentoo-e90abf4be37ca322749be5f0f088f6c07ee20b82.zip
app-shells/autojump: fix patching for Prefix
Closes: https://bugs.gentoo.org/665270 Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--app-shells/autojump/autojump-22.5.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-shells/autojump/autojump-22.5.3.ebuild b/app-shells/autojump/autojump-22.5.3.ebuild
index fe3883cf63eb..71bd16bed2f7 100644
--- a/app-shells/autojump/autojump-22.5.3.ebuild
+++ b/app-shells/autojump/autojump-22.5.3.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-inherit bash-completion-r1 python-r1 vcs-snapshot
+inherit bash-completion-r1 python-r1 vcs-snapshot prefix
DESCRIPTION="change directory command that learns"
HOMEPAGE="https://github.com/wting/autojump"
@@ -24,13 +24,14 @@ DEPEND="${PYTHON_DEPS}"
src_prepare() {
eapply_user
- sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
- -e "s:/usr/local/share:/usr/share:" \
+ sed -e "s:/usr/local/share:/usr/share:" \
-i bin/autojump.sh || die
# autojump_argparse is only there for Python 2.6 compatibility
sed -e "s:autojump_argparse:argparse:" \
-i bin/autojump || die
+
+ hprefixify -q '"' -w '/usr\/share/' bin/autojump.sh
}
src_compile() {