summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-12-21 15:58:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-12-21 16:51:26 +0100
commite992cf3502871f7a03cf291f7a4b4be02d970327 (patch)
tree7df9bb12428620c47322d552abc4d644c282b707
parentdev-libs/urdfdom_headers: bump to 1.0.2 (diff)
downloadgentoo-e992cf3502871f7a03cf291f7a4b4be02d970327.tar.gz
gentoo-e992cf3502871f7a03cf291f7a4b4be02d970327.tar.bz2
gentoo-e992cf3502871f7a03cf291f7a4b4be02d970327.zip
dev-util/rosdep: bump to 0.13.0; update EAPI
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-util/rosdep/Manifest1
-rw-r--r--dev-util/rosdep/rosdep-0.13.0.ebuild62
-rw-r--r--dev-util/rosdep/rosdep-9999.ebuild7
3 files changed, 67 insertions, 3 deletions
diff --git a/dev-util/rosdep/Manifest b/dev-util/rosdep/Manifest
index 2d9708efe29f..fe487c6fd759 100644
--- a/dev-util/rosdep/Manifest
+++ b/dev-util/rosdep/Manifest
@@ -1,2 +1,3 @@
DIST rosdep-0.12.1.tar.gz 117102 BLAKE2B 42b0f6e7b6b0c2a4219bce24ff74ec01efb61ac0799a89baa5dc7f6b698e8f69a1578f744179252e7123c87c9fb0368b43a9a293609b28f6bfbc32c87b5f4627 SHA512 031bdfb4877865cacfab63a4494807ecf157d8514e89c7ab15e38fcbd4664df1247874975d7b1af42a8a1fc24cb62a558bd6b43732946f3122ffa6448a7631da
DIST rosdep-0.12.2.tar.gz 118343 BLAKE2B 98163feef406707772a54bf6d1825900ac593113d635de92adcac0ae7ce201c2e312116104c76c13b9c1e3b1847ef4dcc0cfb4fd1edcb2795c6b323fa9cc7167 SHA512 0932a5ff9874bbdffa1160fe0a391d27eef9a2f2435d7a89fa3b5e4eab0fc08205d4417aaea1254ab7bfe679cfeb61a6f1b199f06d65154b30505e2a280c0b61
+DIST rosdep-0.13.0.tar.gz 301327 BLAKE2B 39c39903bb2e6c07dfd4e3aa9546acf434498db518c3bda04ef79c46ed5d13b7cd55978c78bea8294d8e5b84ddddef22814436566f3f958d91d3964650399a08 SHA512 c42aa17ee9b31f7013415e99a484a66a7a7fb52abef4cc9045658150ce0c36b475f2885ebfff537f9ce9f8fd5eeaef5482226c5bff5b4a3df03cc72b149db07a
diff --git a/dev-util/rosdep/rosdep-0.13.0.ebuild b/dev-util/rosdep/rosdep-0.13.0.ebuild
new file mode 100644
index 000000000000..d406809d630f
--- /dev/null
+++ b/dev-util/rosdep/rosdep-0.13.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tool for installing ROS system dependencies"
+HOMEPAGE="http://wiki.ros.org/rosdep"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/nose[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+}
+
+pkg_postrm() {
+ if [ "${ROOT:-/}" = "/" ] ; then
+ einfo "Removing rosdep default sources list."
+ rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
+ einfo "Initializing rosdep"
+ rosdep init
+ fi
+}
diff --git a/dev-util/rosdep/rosdep-9999.ebuild b/dev-util/rosdep/rosdep-9999.ebuild
index 842ec4941e9e..d406809d630f 100644
--- a/dev-util/rosdep/rosdep-9999.ebuild
+++ b/dev-util/rosdep/rosdep-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
@@ -33,7 +33,8 @@ RDEPEND="
dev-python/rospkg[${PYTHON_USEDEP}]
dev-python/rosdistro[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-python/nose[${PYTHON_USEDEP}]
test? (
dev-python/coverage[${PYTHON_USEDEP}]