summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-07-29 23:21:38 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-07-30 00:06:23 -0400
commite9948b7d754661f85c05fcb911bf2beccdd4b9ad (patch)
tree9f602c2868678d3664ae20959072f1c0dfdc7ea6
parentdev-ruby/rex-java: initial ebuild, metasploit dep (diff)
downloadgentoo-e9948b7d754661f85c05fcb911bf2beccdd4b9ad.tar.gz
gentoo-e9948b7d754661f85c05fcb911bf2beccdd4b9ad.tar.bz2
gentoo-e9948b7d754661f85c05fcb911bf2beccdd4b9ad.zip
dev-ruby/rex-struct2: initial ebuild, metasploit dep
Package-Manager: portage-2.3.0
-rw-r--r--dev-ruby/rex-struct2/Manifest1
-rw-r--r--dev-ruby/rex-struct2/metadata.xml13
-rw-r--r--dev-ruby/rex-struct2/rex-struct2-0.1.0.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/rex-struct2/Manifest b/dev-ruby/rex-struct2/Manifest
new file mode 100644
index 000000000000..f88e993fb8f2
--- /dev/null
+++ b/dev-ruby/rex-struct2/Manifest
@@ -0,0 +1 @@
+DIST rex-struct2-0.1.0.gem 17920 SHA256 b3fd4474c492d9e376c52d68c0e8b6672e24fa709801207449022377c1d94d38 SHA512 f1e8387ea0963648c13118a0663a146db0e1d47ee732229d0d48ab2f4f55aa3bfcbcc4ef50b74476eacdcedf2b456f78282c32e1fae64ccce64a7944bea31436 WHIRLPOOL 3b943e63fd61773e38ef4d76e9c38d6ceb8c3715af56aa06038467041c0437dd6dd85fd292d2311bd1a865545649cff886b9e881bb10b90601f75d7bb001ec57
diff --git a/dev-ruby/rex-struct2/metadata.xml b/dev-ruby/rex-struct2/metadata.xml
new file mode 100644
index 000000000000..359fccd14829
--- /dev/null
+++ b/dev-ruby/rex-struct2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/rex-struct2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rex-struct2/rex-struct2-0.1.0.ebuild b/dev-ruby/rex-struct2/rex-struct2-0.1.0.ebuild
new file mode 100644
index 000000000000..1af35471ba21
--- /dev/null
+++ b/dev-ruby/rex-struct2/rex-struct2-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating/manipulating C-Style structs"
+HOMEPAGE="https://rubygems.org/gems/rex-struct2"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# doesn't seem to actually run any tests
+RESTRICT=test
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper console ${PN}-console
+ ruby_fakegem_binwrapper setup ${PN}-setup
+}