summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-21 08:36:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-21 08:42:24 +0200
commitea0e2b73e3f434d77a29c852197f574ea06cb3de (patch)
tree5a95094a6c0a46e2d969fa939347c78a941faf20
parentnet-wireless/gr-baz: Remove last-rited pkg (diff)
downloadgentoo-ea0e2b73e3f434d77a29c852197f574ea06cb3de.tar.gz
gentoo-ea0e2b73e3f434d77a29c852197f574ea06cb3de.tar.bz2
gentoo-ea0e2b73e3f434d77a29c852197f574ea06cb3de.zip
dev-python/botocore: Bump to 1.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 75ece7a9de97..027c767258cc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -21,3 +21,4 @@ DIST botocore-1.18.7.tar.gz 6854828 BLAKE2B d4b3095d29fea7157ca8b549972688652794
DIST botocore-1.18.8.tar.gz 6865779 BLAKE2B 5b67b67deba73a0a69d4b413bfb105b3eeae5d62a38b0f109d172652270e490eed55b42c8a67c14039aec3f8f0b8b1d1dd9d6945bf9c86d1466bf69d4dc4237f SHA512 467b8ac3c3860777efbf37868add24fc56eecf65003c03692f45669e4ece965c129e18fe3ee0e1ed75b02c886f5762186572927c5e99b3eae85724d7443072d4
DIST botocore-1.18.9.tar.gz 6897783 BLAKE2B 7b449d58febdf3ca3f04bd75e30c3953d6701e5204578a99ce011cce28c5fb30341da5120d2c105b1240ac20dbe80fbfe958d2c5055a04b688ad099fb616342b SHA512 2cfc6c633a216ad091f02021966b3233bdb41f3bfd46c8c6f13bc7ab653024aba21eeb310c87112ad210385fc2316f77117c9ddf26ed0f0df82971b53dd7223b
DIST botocore-1.19.0.tar.gz 6943838 BLAKE2B 03cf575de2880d1254304cc8ba1b0874776aa524efd8204b6d07e2df1abc0bb9f644e675c267037a3a96d3d2229c49287086fc8e87facb67c06a8402d8e81258 SHA512 f32cff5b416fa7148d14d13ec8c0dda8aeac93b461f1774c4ae7d3c1f51e5de54102a8a50a59faffc4e7b6f19729adb3c86f41366652a7d049ebd96aa807f2b8
+DIST botocore-1.19.1.tar.gz 6944577 BLAKE2B ade1c8c3318971f25220d2c5bf82879d9a1cf30ed49066d4d13bf04351dc2fa7a910fcba6dba248d33bcf3e244c8b99c7df66cc3edc6f65b38b8ff2412a68e34 SHA512 e0fd4e8c4fca53c7e034e840ffd9f362c3a41a898188980a382d528334204d13a9dcd597b4a1eb8ce792ffb31e31213167b8e6e952353c339612755b88c1c635
diff --git a/dev-python/botocore/botocore-1.19.1.ebuild b/dev-python/botocore/botocore-1.19.1.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}