summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 02:17:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 15:31:16 +0100
commitea3d5b9ccba225aa4e9f93ba63c838bfc6b816fc (patch)
treec5715675f513713b8630a8f0ca9812aaffc61158
parentapp-emulation/gallium-nine-standalone: New package (diff)
downloadgentoo-ea3d5b9ccba225aa4e9f93ba63c838bfc6b816fc.tar.gz
gentoo-ea3d5b9ccba225aa4e9f93ba63c838bfc6b816fc.tar.bz2
gentoo-ea3d5b9ccba225aa4e9f93ba63c838bfc6b816fc.zip
dev-python/geoip-python: Drop 1.3.2 (r0)
No ppc revdeps. Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/geoip-python/geoip-python-1.3.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/geoip-python/geoip-python-1.3.2.ebuild b/dev-python/geoip-python/geoip-python-1.3.2.ebuild
deleted file mode 100644
index 16ee2baa878a..000000000000
--- a/dev-python/geoip-python/geoip-python-1.3.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="geoip-api-python"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for GeoIP"
-HOMEPAGE="https://github.com/maxmind/geoip-api-python"
-SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~x86-fbsd"
-IUSE="examples test"
-
-RDEPEND=">=dev-libs/geoip-1.4.8"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( README.rst ChangeLog.md )
-
-python_compile() {
- if [[ python_is_python3 || "$EPYTHON}" == 'pypy3' ]]; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}