summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-17 07:37:35 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-17 08:34:58 +0100
commiteaf356158863f900c04362bc531624cb5f1f27ca (patch)
tree6d15c7465dc0b2b3b30639b3238e65a89a1e0448
parentdev-python/hypothesis: Drop redundant versions (diff)
downloadgentoo-eaf356158863f900c04362bc531624cb5f1f27ca.tar.gz
gentoo-eaf356158863f900c04362bc531624cb5f1f27ca.tar.bz2
gentoo-eaf356158863f900c04362bc531624cb5f1f27ca.zip
dev-python/sortedcontainers: Bump to 2.1.0, py3.8, pypy*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sortedcontainers/Manifest1
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/Manifest b/dev-python/sortedcontainers/Manifest
index dc0af7e9443d..296207483913 100644
--- a/dev-python/sortedcontainers/Manifest
+++ b/dev-python/sortedcontainers/Manifest
@@ -1 +1,2 @@
+DIST python-sortedcontainers-2.1.0.gh.tar.gz 9220860 BLAKE2B a667fa817f0b240b8af9758d5d3942710cfe6a39109c41e6e66d0dd464b300d2201a679335e418442aaa6e1953e38a43b46c2bd6ce631b7c168d6173ca36998e SHA512 1c56daea5d491dbeea9c677677a79ef5c4805325ea3d5da97005cd3b269003a99459550a793dfe65820f152c774371472ba471a7daf61c9d97b36744bafb013b
DIST sortedcontainers-1.5.7.tar.gz 11970881 BLAKE2B 0ffdc19a9be82481e71a7ef59391166e19c44d7fc4eac7696d153cac707fdc4beb84a36039e3f1e194c43dc9e956eaae5dfd909f24ef12db4ea99c8548475cab SHA512 a9f2ba152c47eddfda6ad8ef7ecfbfa5d51b17afb4042b0b1e6d8b3dbc6caf6f8281af415dfcf1e356aaf80aa3212865ba926fe0d6e08961c8fbbc68adb34108
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.1.0.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.1.0.ebuild
new file mode 100644
index 000000000000..0a78e3e80e0c
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/
+ https://pypi.org/project/sortedcontainers/
+ https://github.com/grantjenks/python-sortedcontainers/"
+SRC_URI="
+ https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ PYTHONPATH= \
+ pytest -vv --ignore docs/conf.py || die "Tests fail with ${EPYTHON}"
+}