summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-01 06:43:40 +0100
committerHans de Graaff <graaff@gentoo.org>2016-03-01 06:48:37 +0100
commitec4c74856a9bb9f5ba4e2652e52fab6085ac9537 (patch)
tree02662978ccddf28dd6cbce67b0ca40c30f726cc6
parentdev-ruby/activejob: add rails 4.2.5.2, bug 576068 (diff)
downloadgentoo-ec4c74856a9bb9f5ba4e2652e52fab6085ac9537.tar.gz
gentoo-ec4c74856a9bb9f5ba4e2652e52fab6085ac9537.tar.bz2
gentoo-ec4c74856a9bb9f5ba4e2652e52fab6085ac9537.zip
dev-ruby/actionview: add rails 4.2.5.2, bug 576068
Package-Manager: portage-2.2.26
-rw-r--r--dev-ruby/actionview/Manifest1
-rw-r--r--dev-ruby/actionview/actionview-4.2.5.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/actionview/Manifest b/dev-ruby/actionview/Manifest
index 827338072bce..7978d9fc7c5b 100644
--- a/dev-ruby/actionview/Manifest
+++ b/dev-ruby/actionview/Manifest
@@ -1,2 +1,3 @@
DIST rails-4.1.14.1.tgz 3728574 SHA256 1b094a1d1f242c19d2fad0b4f0708d117fce281162d7550535a79c2919246179 SHA512 1ffb3d7f1f5b6db34bbae2015c220945fd780e42bc69242fdcadc6bd59b74c32f16cf54e153b9c3c2aa065d20b1231c19c7ebfe8f8d5f52a1048b8e0f1b7782a WHIRLPOOL 31eb9281d9e0b0e0c07807b14d7b1e52b1a08adc612da9c9c272a5eacb6b095d74b80400eb99818d37371963775942b9d85f38c18446d75de996595528fdf84d
DIST rails-4.2.5.1.tgz 4175926 SHA256 713da4f88244101457b4de5d08007f4b373cb43c3982d72de70bb5c5145afb46 SHA512 3c74d825f35a71dd80a0e1d3959cc6d9e52da0f2eb43bfb869da22a8117ba4f66df1de183851b7cd9e3c2cc8a0b5a8ae4e6902d3b43afd52ccdd20470b49801d WHIRLPOOL dfb4f925468cfbadd73fd54eb146e377df8e4d67aa094076dd928c616d6cfddb9084cee2adb220490df0c34627a99b150118bc7827b2ca5f6d0751611993b53f
+DIST rails-4.2.5.2.tgz 4174380 SHA256 c5dfe36d5ac69f2a852665c2025d289a4d57dc204209b4b3013dcbd0d33f544f SHA512 f2dc1b86c296c9b3862d050a6471f4c529bb246cee6a18106e3e48f588d6a5d665529c95ab94c7d8a9197bf247869805ef908d1255e67641e2cc906e15dcd2e3 WHIRLPOOL 4d933582683d2838fee5d042c1e783afb790a0197b3470969ead3eb79f263cc4862b51bfb30e6a14552473813a8dca237c7241c78f4cc8279c267ba692cbf5d6
diff --git a/dev-ruby/actionview/actionview-4.2.5.2.ebuild b/dev-ruby/actionview/actionview-4.2.5.2.ebuild
new file mode 100644
index 000000000000..65eaceb6cbf6
--- /dev/null
+++ b/dev-ruby/actionview/actionview-4.2.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1:* =dev-ruby/builder-3*:*
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/rails-html-sanitizer-1.0.2:1
+ >=dev-ruby/rails-dom-testing-1.0.5:1
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|rack-cache\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}