summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErvin Peters <coder@ervnet.de>2019-01-13 19:13:06 +0100
committerAgostino Sarubbo <ago@gentoo.org>2019-02-15 16:04:00 +0100
commitec786164484f592edf7bb7404ff734bc2659c009 (patch)
tree8a0565325085bf41f7914079843403b920b23aa7
parentsys-kernel/vanilla-sources: Automated version bump to {4.9.158,4.14.101,4.19.... (diff)
downloadgentoo-ec786164484f592edf7bb7404ff734bc2659c009.tar.gz
gentoo-ec786164484f592edf7bb7404ff734bc2659c009.tar.bz2
gentoo-ec786164484f592edf7bb7404ff734bc2659c009.zip
app-editors/scite: Version bump scite-4.1.3
additionally see PR #10562 for previous Version and cleanup Signed-off-by: Ervin Peters <ervin.peters@ervnet.de> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-editors/scite/Manifest1
-rw-r--r--app-editors/scite/scite-4.1.3.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index ac744de0d36a..661060c12fb7 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,3 +1,4 @@
+DIST scite-4.1.3.tgz 2546247 BLAKE2B 9c0cd767e6aff861bb706500eebf5fa431d5ce608f37a9b19d2af7d558698eb3073a33fcdd0900abb549aa9ed65981a9f217dc1dae4b21be919c380d20d4ee8f SHA512 875dd44785e9c96a264df9061830c7ab51296061da7765084ec4445d7f529dabecebcfadc5a1d8cab9074ffd588903ca056ed5de0ae974d60a5c57b13d61550d
DIST scite355.tgz 2302137 BLAKE2B 5b36c68a5447b7fd0dd2fce51fc09cec0ee4a86be10f4f32fa7bf47354c56424cbead6cdfe819c8014be75e843c867ccaa137c5f7e32c3f9b0dabb6b9a5a9cb3 SHA512 cdd9d3aa621f5d31632cfb9f71524255a4b47b70a654bf4bc8a25a76f8a2dbe098a48e0cd4587ced8ca8455be7e809973e212fcbcde5b62087aa0f9528f7f40d
DIST scite365.tgz 2391190 BLAKE2B 0cd2b1b24bcd15815357125725b1453935dc944ca1ddbd77772923ceeb249b3182dc47cb1e1097a4e0942b3a5c7528d0e80fe2314ed9d3d2b7f4e960a0f17ff2 SHA512 193dcb1f8787a7c7d520ce62462e5c95e7b6bcaf79f4ab23f9885474fb0444dbc5a69a0d45eafc592e5fff2a2e746a9aba599799e847e3c74d3436eed26580a9
DIST scite402.tgz 2424648 BLAKE2B 84a331865310058d26ca45a25b99d98a7c3374d0463024e31694e2ebbd519a20e8e368dc1dfabc2534e8f015fc95ca53382bc223476b882a7be543ffdc44ae2b SHA512 97898cbb8675d013dd91828792de1c71e3f013b21c59c5112ddc00e7ee35c2ba8cc29e2c3256b91171e052145a25cddfd0034505e3c185999c734504bb702283
diff --git a/app-editors/scite/scite-4.1.3.ebuild b/app-editors/scite/scite-4.1.3.ebuild
new file mode 100644
index 000000000000..fd4938711afc
--- /dev/null
+++ b/app-editors/scite/scite-4.1.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils toolchain-funcs xdg-utils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
+HOMEPAGE="http://www.scintilla.org/SciTE.html"
+SRC_URI="https://www.scintilla.org/${PN}${MY_PV}.tgz -> ${P}.tgz"
+
+LICENSE="HPND lua? ( MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="lua"
+
+RDEPEND="
+ dev-libs/glib:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3=
+ x11-libs/pango
+ lua? ( >=dev-lang/lua-5:= )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}/gtk"
+
+pkg_pretend() {
+ if tc-is-clang ; then
+ # need c++17 features
+ [[ "${MERGE_TYPE}" != "binary" &&
+ $(clang-major-version) -lt 5 ]] &&
+ die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5
+ ($(clang-major-version))."
+
+ elif tc-is-gcc; then
+ # older gcc is not supported
+ [[ "${MERGE_TYPE}" != "binary" &&
+ $(gcc-major-version) -lt 7 ]] &&
+ die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7."
+ else
+ die "Either gcc or clang should be configured for building scite"
+ fi
+}
+
+src_prepare() {
+ # remove hardcoded CC, Optimizations and clang unknown flags
+ sed -i "${WORKDIR}/scintilla/gtk/makefile" \
+ -e "s#^CC = gcc#CC = ${CC}#" \
+ -e "s#^CC = clang#CC = ${CC}#" \
+ -e "s#^CXX = clang++#CC = ${CXX}#" \
+ -e "s#-Os##" \
+ -e "s#-Wno-misleading-indentation##" \
+ || die "error patching /scintilla/gtk/makefile"
+
+ sed -i "${S}/makefile" \
+ -e "s#^CC = clang#CC = ${CC}#" \
+ -e "s#^CXX = clang++#CC = ${CXX}#" \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ -e "s#-Os##" \
+ || die "error patching gtk/makefile"
+
+ # repair and enhance the .desktop file
+ sed -i "${S}/SciTE.desktop" \
+ -e "s#text/plain#text/\*;application/xhtml+xml#" \
+ -e "s#^Categories=\(.*\)#Categories=Development;#" \
+ || die "error patching /scite/gtk/SciTe.desktop"
+
+ # add the ebuild suffix as shell type for working with ebuilds
+ sed -i "${WORKDIR}/scite/src/perl.properties" \
+ -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
+ || die "error patching /scite/src/perl.prperties"
+
+ # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
+ # Bug #576162
+
+ cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
+ eapply_user
+}
+
+src_compile() {
+ # prepare make options
+ local emake_pars="GTK3=1"
+
+ if tc-is-clang ; then
+ emake_pars+=" CLANG=1"
+ fi
+
+ if ! use lua; then
+ emake_pars+=" NO_LUA=1"
+ fi
+
+ emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars}"
+ emake "${emake_pars}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${ED}/usr/bin/SciTE" "${ED}/usr/bin/scite" || die
+ dosym scite /usr/bin/SciTE
+ doman ../doc/scite.1
+ dodoc ../README
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}