summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2019-10-22 00:07:36 +0300
committerMaxim Koltsov <maksbotan@gentoo.org>2019-10-22 23:37:56 +0300
commitecefbd1b813fafcc718b8ec843d73b6c6ad8dd9f (patch)
treef03b85ed961c488075e42f5882aef5e22d2bc017
parentdev-python/pip: bump to 19.3.1 (diff)
downloadgentoo-ecefbd1b813fafcc718b8ec843d73b6c6ad8dd9f.tar.gz
gentoo-ecefbd1b813fafcc718b8ec843d73b6c6ad8dd9f.tar.bz2
gentoo-ecefbd1b813fafcc718b8ec843d73b6c6ad8dd9f.zip
dev-python/pip: drop old
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Maxim Koltsov <maksbotan@gentoo.org>
-rw-r--r--dev-python/pip/Manifest2
-rw-r--r--dev-python/pip/files/pip-10.0.1-disable-system-install.patch18
-rw-r--r--dev-python/pip/files/pip-10.0.1-disable-version-check.patch19
-rw-r--r--dev-python/pip/files/pip-6.0.2-disable-version-check.patch14
-rw-r--r--dev-python/pip/files/pip-8.0.0-unbundle.patch43
-rw-r--r--dev-python/pip/pip-10.0.1.ebuild48
-rw-r--r--dev-python/pip/pip-19.2.2.ebuild97
7 files changed, 0 insertions, 241 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index f28dd7099370..035862b63100 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,6 +1,4 @@
-DIST pip-10.0.1.tar.gz 1246072 BLAKE2B e08607be43e1d7b9c7bbc12dff73bc3170953f48f8f7439a0b27b9d540f23eb3bca7873211a5f1448b5cedd6e8e12983af6fa4666bba3ac4700059d170036733 SHA512 983cce8375ff0304263209c69be16e5be7a58af340b8c3ffddd64fcea130b2f8f8a98305ab31e9c3eed9a0d039c73777c88bde3bf2ea1e184fa3e0a2faa97fd4
DIST pip-19.1.tar.gz 6320747 BLAKE2B 9b69fcdef751d6938a7c67f44692afa7088f660ab1e0ae113d21d0f48b4e29f43e0f0bcc137cf16ac0324ea3b500bd2a84234823f8d82556d6727f68139aab4b SHA512 0d2442c22c41133118353ba98f45260f0615a891725b2a069d8fbf26ec4033cc7297bb671944c3dcc1f68800b91e92e58fb407ca5a333382e20ac4bb5c9e0cb6
-DIST pip-19.2.2.tar.gz 6381643 BLAKE2B 3c7d3c070d9bc52557b67c8fc34274d8c769179e01758b63d69c5da48d94a5980ecba62f8b74135ee2f08b4686f8835dee5da5d30fc12af0044f7f0180b3f50b SHA512 ca634925e21aba338aa65f80d258833c6622b4c1d85eaf827fa5439aed62d7c6d64fde91cfebc05bd83eb215b019b690379cf5c4ac85a2f32d6357e6bd95fd88
DIST pip-19.3.1.tar.gz 6409819 BLAKE2B b3aacd0bee60400a1f30b4be57871002072e5cc7a86e76cca1848e977ebdc85b6e282fc521c19bf7a518d1aef3280133fcd65a431cb2a16e202dd7721c5b97ad SHA512 39446c0ab6e4495d98f22923a2a76901b024d9047b60d92580b21d447a718e5285cfd66f8ad0c20befcfe1abc7f06be29b6a5644d1b30265d3b67399fe76e033
DIST pip-9.0.1.tar.gz 1197370 BLAKE2B 3618161690d5e0a38d141f9b51baea4aaa3fdc225664ef180bbeecf6e2df95e9ea4f97c63fe3a68f84f4fb5ebcc74e316827253c7e07b03565e58113bbaa918a SHA512 ee59efb4b009ff6543b7afdea99b9cbbee1981ecc03af586acda76674024d3b66dab23049e68f3da9448734984619fc1eaba6e965c9dd3d731973376c8a42e25
DIST setuptools-41.0.1-py2.py3-none-any.whl 575966 BLAKE2B 332986453a35e4ec36ab2bdb80a8b0a70ffe4fec1bb874f481b0d8e31016a26d53070f90d0eea9030b8c48a1f9bc21a54d8a5a2b70096e1f8db84d42449903e4 SHA512 c84ddf1d1ea90216b2c475f3e4879f4e6792a859adf61db70d67f49a35f2cb4df6fd6d93049881e6d2a8d914768edfcd091475206bb5da3ac66c41c4b9147102
diff --git a/dev-python/pip/files/pip-10.0.1-disable-system-install.patch b/dev-python/pip/files/pip-10.0.1-disable-system-install.patch
deleted file mode 100644
index 776d395b7b94..000000000000
--- a/dev-python/pip/files/pip-10.0.1-disable-system-install.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-install: Raise an error to avoid breaking python-exec
-
-Running pip without --target, --root, or --user will result in packages
-being installed systemwide. This has a tendency to break python-exec if
-setuptools gets installed or upgraded.
-
---- pip-10.0.1/src/pip/_internal/commands/install.py
-+++ pip-10.0.1/src/pip/_internal/commands/install.py
-@@ -202,6 +202,9 @@
- if options.upgrade:
- upgrade_strategy = options.upgrade_strategy
-
-+ if not options.use_user_site and not options.target_dir and not options.root_path:
-+ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
-+
- if options.build_dir:
- options.build_dir = os.path.abspath(options.build_dir)
-
diff --git a/dev-python/pip/files/pip-10.0.1-disable-version-check.patch b/dev-python/pip/files/pip-10.0.1-disable-version-check.patch
deleted file mode 100644
index ad146dc1507f..000000000000
--- a/dev-python/pip/files/pip-10.0.1-disable-version-check.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Don't check for new versions of pip.
-
---- pip-10.0.1/src/pip/_internal/basecommand.py
-+++ pip-10.0.1/src/pip/_internal/basecommand.py
-@@ -255,14 +255,6 @@
-
- return UNKNOWN_ERROR
- finally:
-- # Check if we're using the latest version of pip available
-- if (not options.disable_pip_version_check and not
-- getattr(options, "no_index", False)):
-- with self._build_session(
-- options,
-- retries=0,
-- timeout=min(5, options.timeout)) as session:
-- pip_version_check(session, options)
- # Avoid leaking loggers
- for handler in set(logging.root.handlers) - original_root_handlers:
- # this method benefit from the Logger class internal lock
diff --git a/dev-python/pip/files/pip-6.0.2-disable-version-check.patch b/dev-python/pip/files/pip-6.0.2-disable-version-check.patch
deleted file mode 100644
index a192c228a997..000000000000
--- a/dev-python/pip/files/pip-6.0.2-disable-version-check.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Don't check PyPI for new versions of pip by default, updates will occur when
-new releases are added to the tree.
-
---- pip-6.0.2/pip/cmdoptions.py
-+++ pip-6.0.2/pip/cmdoptions.py
-@@ -404,7 +404,7 @@
- "--disable-pip-version-check",
- dest="disable_pip_version_check",
- action="store_true",
-- default=False,
-+ default=True,
- help="Don't periodically check PyPI to determine whether a new version "
- "of pip is available for download.")
-
diff --git a/dev-python/pip/files/pip-8.0.0-unbundle.patch b/dev-python/pip/files/pip-8.0.0-unbundle.patch
deleted file mode 100644
index d508d51ab4fc..000000000000
--- a/dev-python/pip/files/pip-8.0.0-unbundle.patch
+++ /dev/null
@@ -1,43 +0,0 @@
- pip/_vendor/__init__.py | 15 +++++----------
- 1 file changed, 5 insertions(+), 10 deletions(-)
-
-diff --git a/pip/_vendor/__init__.py b/pip/_vendor/__init__.py
-index b09a7c3..b9fe6ee 100644
---- a/pip/_vendor/__init__.py
-+++ b/pip/_vendor/__init__.py
-@@ -14,7 +14,7 @@ import sys
- # Downstream redistributors which have debundled our dependencies should also
- # patch this value to be true. This will trigger the additional patching
- # to cause things like "six" to be available as pip.
--DEBUNDLED = False
-+DEBUNDLED = True
-
- # By default, look in this directory for a bunch of .whl files which we will
- # add to the beginning of sys.path before attempting to import anything. This
-@@ -29,13 +29,10 @@ WHEEL_DIR = os.path.abspath(os.path.dirname(__file__))
- def vendored(modulename):
- vendored_name = "{0}.{1}".format(__name__, modulename)
-
-- try:
-- __import__(vendored_name, globals(), locals(), level=0)
-- except ImportError:
-- __import__(modulename, globals(), locals(), level=0)
-- sys.modules[vendored_name] = sys.modules[modulename]
-- base, head = vendored_name.rsplit(".", 1)
-- setattr(sys.modules[base], head, sys.modules[modulename])
-+ __import__(modulename, globals(), locals(), level=0)
-+ sys.modules[vendored_name] = sys.modules[modulename]
-+ base, head = vendored_name.rsplit(".", 1)
-+ setattr(sys.modules[base], head, sys.modules[modulename])
-
-
- # If we're operating in a debundled setup, then we want to go ahead and trigger
-@@ -85,8 +82,6 @@ if DEBUNDLED:
- vendored("requests.packages.urllib3.packages.ordered_dict")
- vendored("requests.packages.urllib3.packages.six")
- vendored("requests.packages.urllib3.packages.ssl_match_hostname")
-- vendored("requests.packages.urllib3.packages.ssl_match_hostname."
-- "_implementation")
- vendored("requests.packages.urllib3.poolmanager")
- vendored("requests.packages.urllib3.request")
- vendored("requests.packages.urllib3.response")
diff --git a/dev-python/pip/pip-10.0.1.ebuild b/dev-python/pip/pip-10.0.1.ebuild
deleted file mode 100644
index 19a0c39cdd04..000000000000
--- a/dev-python/pip/pip-10.0.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit eutils bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="https://pip.pypa.io/ https://pypi.org/project/pip/ https://github.com/pypa/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="-vanilla"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-10.0.1-disable-version-check.patch"
- )
- if ! use vanilla; then
- PATCHES+=( "${FILESDIR}/pip-10.0.1-disable-system-install.patch" )
- fi
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- "${PYTHON}" -m pip completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- "${PYTHON}" -m pip completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
-}
diff --git a/dev-python/pip/pip-19.2.2.ebuild b/dev-python/pip/pip-19.2.2.ebuild
deleted file mode 100644
index 1d2a8c7a3721..000000000000
--- a/dev-python/pip/pip-19.2.2.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit bash-completion-r1 distutils-r1 multiprocessing
-
-SETUPTOOLS_PV="41.0.1"
-WHEEL_PV="0.33.1"
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="https://pip.pypa.io/ https://pypi.org/project/pip/ https://github.com/pypa/pip/"
-SRC_URI="
- https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- test? (
- https://files.pythonhosted.org/packages/py2.py3/s/setuptools/setuptools-${SETUPTOOLS_PV}-py2.py3-none-any.whl
- https://files.pythonhosted.org/packages/py2.py3/w/wheel/wheel-${WHEEL_PV}-py2.py3-none-any.whl
- )
-"
-# PyPI archive does not have tests, so we need to download from GitHub.
-# setuptools & wheel .whl files are required for testing, exact version is not very important.
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="test -vanilla"
-
-# disable-system-install patch breaks tests
-RESTRICT="!vanilla? ( test )"
-
-RDEPEND="
- >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- <dev-python/pytest-4[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- <dev-python/pytest-rerunfailures-7.0[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- <dev-python/pytest-xdist-1.28.0[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/scripttest[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-19.1-disable-version-check.patch"
- )
- if ! use vanilla; then
- PATCHES+=( "${FILESDIR}/pip-19.1-disable-system-install.patch" )
- fi
- distutils-r1_python_prepare_all
-
- if use test; then
- mkdir tests/data/common_wheels/
- cp "${DISTDIR}"/setuptools-${SETUPTOOLS_PV}-py2.py3-none-any.whl tests/data/common_wheels/ || die
- cp "${DISTDIR}"/wheel-${WHEEL_PV}-py2.py3-none-any.whl tests/data/common_wheels/ || die
- fi
-}
-
-python_test () {
- # Exclude tests that fail for some reason. Some of these failures may be Gentoo-specific.
- python -m pytest \
- -n $(makeopts_jobs) \
- --timeout 300 \
- -k "not (svn or git or bazaar or mercurial or test_pep518_uses_build_env or test_install_package_with_root or test_install_editable_with_prefix or install_from_user or install_user_conflict or upgrade_user_conflict or build_env_isolation or config_file_venv_option or get_legacy_build_wheel or install_user_wheel or uninstall_non_local_distutils or install_from_current_directory_into_usersite or uninstall_editable_from_usersite)" \
- -m "not network" \
- || die
-}
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/html/**/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- # 'pip completion' command embeds full $0 into completion script, which confuses
- # 'complete' and causes QA warning when running as "${PYTHON} -m pip".
- # This trick sets correct $0 while still calling just installed pip.
- local pipcmd='import sys; sys.argv[0] = "pip"; import pip.__main__; sys.exit(pip.__main__._main())'
-
- ${PYTHON} -c "${pipcmd}" completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- ${PYTHON} -c "${pipcmd}" completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
-}