summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-16 07:39:12 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-18 08:47:42 +0200
commited1b66b63aca241539ec9acca6368170328d4f45 (patch)
treec5dc0d31676fea4598afe4245455f09fee41ddb4
parentsys-process/cronie: Stable for HPPA PPC64 (bug #587796). (diff)
downloadgentoo-ed1b66b63aca241539ec9acca6368170328d4f45.tar.gz
gentoo-ed1b66b63aca241539ec9acca6368170328d4f45.tar.bz2
gentoo-ed1b66b63aca241539ec9acca6368170328d4f45.zip
dev-ruby/loofah: fix tests, add ruby23
Package-Manager: portage-2.2.28
-rw-r--r--dev-ruby/loofah/loofah-2.0.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/loofah/loofah-2.0.3.ebuild b/dev-ruby/loofah/loofah-2.0.3.ebuild
index 18e3abc713d7..8403de326b7b 100644
--- a/dev-ruby/loofah/loofah-2.0.3.ebuild
+++ b/dev-ruby/loofah/loofah-2.0.3.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
@@ -25,4 +25,7 @@ ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 >=dev-ruby/hoe-2.3.0 )"
all_ruby_prepare() {
# Avoid test failing on different whitespace.
sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+
+ # Fix test for new libxml2 results (fixed upstream)
+ sed -i -e '348i "xhtml": "&lt;&lt;script&gt;alert(\\\"XSS\\\");//&lt;&lt;/script&gt;",' test/assets/testdata_sanitizer_tests1.dat || die
}