summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-17 22:26:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-28 11:35:02 +0200
commitee091aee139709096dfb06af429de8c88105b69a (patch)
tree1183351122444cf16cf00338618a4975c9341240
parentkde-misc/kio-gdrive: Drop old (diff)
downloadgentoo-ee091aee139709096dfb06af429de8c88105b69a.tar.gz
gentoo-ee091aee139709096dfb06af429de8c88105b69a.tar.bz2
gentoo-ee091aee139709096dfb06af429de8c88105b69a.zip
kde5.eclass: Don't remove cmake_modules, simplify filtering LINGUAS
Recent changes in KDE Applications packaging added a new directory 'cmake_modules' for some type of data content inside po/${lang}/
-rw-r--r--eclass/kde5.eclass13
1 files changed, 7 insertions, 6 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 60d8f131f1ce..71839733485c 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -566,17 +566,18 @@ kde5_src_prepare() {
pushd ${po} > /dev/null || die
local lang
for lang in *; do
- if [[ -d ${lang} ]] && ! has ${lang} ${LINGUAS} ; then
- rm -r ${lang} || die
+ if [[ -e ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
+ case ${lang} in
+ cmake_modules | \
+ CMakeLists.txt | \
+ ${PN}.pot) ;;
+ *) rm -r ${lang} || die ;;
+ esac
if [[ -e CMakeLists.txt ]] ; then
cmake_comment_add_subdirectory ${lang}
sed -e "/add_subdirectory([[:space:]]*${lang}\/.*[[:space:]]*)/d" \
-i CMakeLists.txt || die
fi
- elif [[ -f ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
- if [[ ${lang} != CMakeLists.txt && ${lang} != ${PN}.pot ]] ; then
- rm ${lang} || die
- fi
fi
done
popd > /dev/null || die