summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-23 22:11:28 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-23 22:32:40 +0100
commitee0c9b5bb373695466c06a621be10a7a13eed2d5 (patch)
tree9e69f39d0fb60bedd6292e6a938dfa8b8b037010
parentnet-misc/asterisk: bumps for SLOTed lua and func_lock races. (diff)
downloadgentoo-ee0c9b5bb373695466c06a621be10a7a13eed2d5.tar.gz
gentoo-ee0c9b5bb373695466c06a621be10a7a13eed2d5.tar.bz2
gentoo-ee0c9b5bb373695466c06a621be10a7a13eed2d5.zip
kde-apps/dolphin: Crash fix
Upstream commit c95d7fae79a309ed7f2df393fa20257cb20d54a8 See also: https://mail.kde.org/pipermail/distributions/2020-December/000913.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=429628 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=430434 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin/dolphin-20.12.0-r1.ebuild99
-rw-r--r--kde-apps/dolphin/files/dolphin-20.12.0-crashfix.patch27
2 files changed, 126 insertions, 0 deletions
diff --git a/kde-apps/dolphin/dolphin-20.12.0-r1.ebuild b/kde-apps/dolphin/dolphin-20.12.0-r1.ebuild
new file mode 100644
index 000000000000..ffeb5b378fe8
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-20.12.0-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.75.0
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://apps.kde.org/en/dolphin https://userbase.kde.org/Dolphin"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="activities semantic-desktop telemetry"
+
+DEPEND="
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kinit-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=media-libs/phonon-4.11.0
+ activities? ( >=kde-frameworks/kactivities-${KFMIN}:5 )
+ semantic-desktop? (
+ >=kde-apps/baloo-widgets-${PVCUT}:5
+ >=kde-frameworks/baloo-${KFMIN}:5
+ >=kde-frameworks/kfilemetadata-${KFMIN}:5
+ )
+ telemetry? ( dev-libs/kuserfeedback:5 )
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/kio-extras-${PVCUT}:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-crashfix.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
+ $(cmake_use_find_package activities KF5Activities)
+ $(cmake_use_find_package semantic-desktop KF5Baloo)
+ $(cmake_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake_use_find_package semantic-desktop KF5FileMetaData)
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+ ecm_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # servicemenuinstaller requires ruby, no thanks
+ # dolphinmainwindowtest, kitemlistcontrollertest, kfileitemlistviewtest, kfileitemmodeltest hang forever
+ # placesitemmodeltest requires DBus
+ -E "(servicemenuinstaller|dolphinmainwindowtest|kfileitemlistviewtest|kfileitemmodeltest|kitemlistcontrollertest|placesitemmodeltest)"
+ )
+ ecm_src_test
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "compress/extract and other actions" kde-apps/ark:${SLOT}
+ optfeature "crypto actions" kde-apps/kleopatra:${SLOT}
+ optfeature "video file thumbnails" kde-apps/ffmpegthumbs:${SLOT}
+ optfeature "graphics file thumbnails" kde-apps/thumbnailers:${SLOT}
+ optfeature "'Share' context menu actions" kde-frameworks/purpose:${SLOT}
+ fi
+ ecm_pkg_postinst
+}
diff --git a/kde-apps/dolphin/files/dolphin-20.12.0-crashfix.patch b/kde-apps/dolphin/files/dolphin-20.12.0-crashfix.patch
new file mode 100644
index 000000000000..65350b7ba3e6
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-20.12.0-crashfix.patch
@@ -0,0 +1,27 @@
+From c95d7fae79a309ed7f2df393fa20257cb20d54a8 Mon Sep 17 00:00:00 2001
+From: Anthony Fieroni <bvbfan@abv.bg>
+Date: Sat, 12 Dec 2020 12:36:23 +0200
+Subject: [PATCH] Fix access url navigator while creating new tab in filename
+ search view BUG: 429628 BUG: 430434
+
+Signed-off-by: Anthony Fieroni <bvbfan@abv.bg>
+---
+ src/dolphinviewcontainer.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/dolphinviewcontainer.cpp b/src/dolphinviewcontainer.cpp
+index 7260d2c4c..8dd309314 100644
+--- a/src/dolphinviewcontainer.cpp
++++ b/src/dolphinviewcontainer.cpp
+@@ -390,7 +390,7 @@ void DolphinViewContainer::setSearchModeEnabled(bool enabled)
+ m_searchBox->setVisible(enabled);
+
+ if (enabled) {
+- const QUrl& locationUrl = m_urlNavigatorConnected->locationUrl();
++ const QUrl& locationUrl = m_urlNavigator->locationUrl();
+ m_searchBox->fromSearchUrl(locationUrl);
+ }
+
+--
+GitLab
+