summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-13 21:52:32 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-13 21:53:03 +0100
commitee0fcacb661a7c3b10874ba3828eb3a27fd824a0 (patch)
tree6a2552b72f508aadf50924e3d203d7b527576d24
parentx11-themes/light-themes: Keep vanilla editions untouched (diff)
downloadgentoo-ee0fcacb661a7c3b10874ba3828eb3a27fd824a0.tar.gz
gentoo-ee0fcacb661a7c3b10874ba3828eb3a27fd824a0.tar.bz2
gentoo-ee0fcacb661a7c3b10874ba3828eb3a27fd824a0.zip
media-libs/alure: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-libs/alure/alure-1.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/alure/alure-1.2-r1.ebuild b/media-libs/alure/alure-1.2-r1.ebuild
new file mode 100644
index 000000000000..8baa987faf45
--- /dev/null
+++ b/media-libs/alure/alure-1.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils eutils
+
+DESCRIPTION="The OpenAL Utility Toolkit"
+HOMEPAGE="http://kcat.strangesoft.net/alure.html"
+SRC_URI="http://kcat.strangesoft.net/alure-releases/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dumb examples flac fluidsynth mp3 sndfile static-libs vorbis"
+
+RDEPEND=">=media-libs/openal-1.1
+ dumb? ( media-libs/dumb )
+ flac? ( media-libs/flac )
+ fluidsynth? ( >=media-sound/fluidsynth-1.1.1 )
+ mp3? ( media-sound/mpg123 )
+ sndfile? ( media-libs/libsndfile )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
+
+PATCJES=( "${FILESDIR}/${P}-include-unistd.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i -e "/DESTINATION/s:doc/alure:doc/${PF}:" CMakeLists.txt || die
+}
+
+src_configure() {
+ # FIXME: libmodplug/sndfile.h from libmodplug conflict with sndfile.h from libsndfile
+ local mycmakeargs=(
+ -DMODPLUG=OFF
+ -DDUMB=$(usex dumb)
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DFLAC=$(usex flac)
+ -DFLUIDSYNTH=$(usex fluidsynth)
+ -DMPG123=$(usex mp3)
+ -DSNDFILE=$(usex sndfile)
+ -DBUILD_STATIC=$(usex static-libs)
+ -DVORBIS=$(usex vorbis)
+ )
+
+ cmake-utils_src_configure
+}