summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-01-08 23:15:06 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-01-08 23:21:27 +0000
commitee5c833546a4e870079e43fc39c434393f53fdef (patch)
tree0a304b5f954e5fdbcd160689fa23727b9f7a983c
parentmedia-libs/glfw-3.3.1 version bump (diff)
downloadgentoo-ee5c833546a4e870079e43fc39c434393f53fdef.tar.gz
gentoo-ee5c833546a4e870079e43fc39c434393f53fdef.tar.bz2
gentoo-ee5c833546a4e870079e43fc39c434393f53fdef.zip
media-libs/glfw: EAPI 7 for 3.3.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--media-libs/glfw/glfw-3.3.1.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/media-libs/glfw/glfw-3.3.1.ebuild b/media-libs/glfw/glfw-3.3.1.ebuild
index fed5798ce2ab..45ce2dcfce0d 100644
--- a/media-libs/glfw/glfw-3.3.1.ebuild
+++ b/media-libs/glfw/glfw-3.3.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
+
+inherit cmake
DESCRIPTION="The Portable OpenGL FrameWork"
HOMEPAGE="https://www.glfw.org/"
@@ -30,10 +31,10 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- wayland? (
- dev-libs/wayland-protocols
- kde-frameworks/extra-cmake-modules
- )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ wayland? ( kde-frameworks/extra-cmake-modules )
"
src_configure() {
@@ -42,5 +43,5 @@ src_configure() {
-DGLFW_USE_WAYLAND="$(usex wayland)"
-DBUILD_SHARED_LIBS=1
)
- cmake-utils_src_configure
+ cmake_src_configure
}