summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2016-10-16 18:24:16 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2016-10-16 18:25:14 +0200
commiteeaf86ea76a58a3289bb6127979e1a060937025a (patch)
tree78d6af679f69b6f298671cfbbf9a0617e42f2bd5
parenteclass/mozcoreconf-v4 : append flags for gcc-6 support (diff)
downloadgentoo-eeaf86ea76a58a3289bb6127979e1a060937025a.tar.gz
gentoo-eeaf86ea76a58a3289bb6127979e1a060937025a.tar.bz2
gentoo-eeaf86ea76a58a3289bb6127979e1a060937025a.zip
media-plugins/vdr-mailbox: compilefix gcc-6; thx to P.Levine on wrt bug 593946
Package-Manager: portage-2.3.0
-rw-r--r--media-plugins/vdr-mailbox/files/vdr-mailbox-0.7.0_gcc-6.patch29
-rw-r--r--media-plugins/vdr-mailbox/vdr-mailbox-0.7.0-r1.ebuild22
2 files changed, 51 insertions, 0 deletions
diff --git a/media-plugins/vdr-mailbox/files/vdr-mailbox-0.7.0_gcc-6.patch b/media-plugins/vdr-mailbox/files/vdr-mailbox-0.7.0_gcc-6.patch
new file mode 100644
index 000000000000..9647ccb09bb9
--- /dev/null
+++ b/media-plugins/vdr-mailbox/files/vdr-mailbox-0.7.0_gcc-6.patch
@@ -0,0 +1,29 @@
+compile fix gcc-6
+https://bugs.gentoo.org/show_bug.cgi?id=593946
+Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2016/Oct/16)
+--- mailbox-0.7.0/Makefile.old 2016-09-21 20:42:01.505376511 -0400
++++ mailbox-0.7.0/Makefile 2016-09-21 20:42:06.071280736 -0400
+@@ -149,7 +149,7 @@
+
+ INCLUDES +=
+
+-DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
++DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"' -D__STL_CONFIG_H
+
+ ### The object files (add further files here):
+
+--- mailbox-0.7.0/AxLib/include/Ax/Tools/Trace.h.old 2016-09-21 20:35:30.849775089 -0400
++++ mailbox-0.7.0/AxLib/include/Ax/Tools/Trace.h 2016-09-21 20:35:35.926564690 -0400
+@@ -40,9 +40,9 @@
+ //-----------------------------------------------------------------------------
+ // define macros for users
+ //-----------------------------------------------------------------------------
+-#define wsdebugsyslog(Y...) dsyslog("mailbox: "Y)
+-#define wswarnsyslog(Y...) isyslog("mailbox: "Y)
+-#define wserrorsyslog(Y...) esyslog("mailbox: "Y)
++#define wsdebugsyslog(Y...) dsyslog("mailbox: " Y)
++#define wswarnsyslog(Y...) isyslog("mailbox: " Y)
++#define wserrorsyslog(Y...) esyslog("mailbox: " Y)
+
+ #define wsdebug(X) do { } while(0);
+ #define wsinfo(X) do { wsdebugsyslog X ;} while(0);
diff --git a/media-plugins/vdr-mailbox/vdr-mailbox-0.7.0-r1.ebuild b/media-plugins/vdr-mailbox/vdr-mailbox-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..0dd397f447fe
--- /dev/null
+++ b/media-plugins/vdr-mailbox/vdr-mailbox-0.7.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: MailBox provides access to multiple e-mail accounts"
+HOMEPAGE="http://alex.vdr-developer.org"
+SRC_URI="http://alex.vdr-developer.org/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.41
+ >=net-libs/c-client-2002e-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}_gcc-6.patch" ) \ No newline at end of file