summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-06-05 07:03:21 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-06-05 07:03:21 +0200
commitf0c46737f8e44a069d1b5aba3f2882dd57f4c8c3 (patch)
treeadd5739fb9ef4690691522f199bce9cadbbfadc1
parentsys-apps/texinfo: Add useflag xs (default off) toggling C in Perl (diff)
downloadgentoo-f0c46737f8e44a069d1b5aba3f2882dd57f4c8c3.tar.gz
gentoo-f0c46737f8e44a069d1b5aba3f2882dd57f4c8c3.tar.bz2
gentoo-f0c46737f8e44a069d1b5aba3f2882dd57f4c8c3.zip
sys-apps/texinfo: -r3, agressively optimizes stability (no keywords)
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--sys-apps/texinfo/metadata.xml1
-rw-r--r--sys-apps/texinfo/texinfo-6.6-r3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/texinfo/metadata.xml b/sys-apps/texinfo/metadata.xml
index e73fd846ffa9..c939b6a3e975 100644
--- a/sys-apps/texinfo/metadata.xml
+++ b/sys-apps/texinfo/metadata.xml
@@ -11,5 +11,6 @@
</maintainer>
<use>
<flag name="xs">Build Perl modules with embedded C code for speed; requires rebuilds on Perl update</flag>
+ <flag name="standalone">Build standalone version that survives all Portage bugs</flag>
</use>
</pkgmetadata>
diff --git a/sys-apps/texinfo/texinfo-6.6-r3.ebuild b/sys-apps/texinfo/texinfo-6.6-r3.ebuild
new file mode 100644
index 000000000000..f2545ebfff42
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.6-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:0=
+ standalone? ( dev-lang/perl )
+ !standalone? (
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions. #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}" PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+ local myeconfargs
+ if use standalone ; then
+ myeconfargs=(
+ --without-external-libintl-perl
+ --without-external-Unicode-EastAsianWidth
+ --without-external-Text-Unidecode
+ $(use_enable nls)
+ --disable-perl-xs
+ )
+ else
+ myeconfargs=(
+ --with-external-libintl-perl
+ --with-external-Unicode-EastAsianWidth
+ --with-external-Text-Unidecode
+ $(use_enable nls)
+ --enable-perl-xs
+ )
+ fi
+ econf "${myeconfargs[@]}"
+}