summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-03-22 15:33:22 -0400
committerRick Farina <zerochaos@gentoo.org>2019-03-22 15:39:04 -0400
commitf0eb78b0281f714dc7506eba410cd1ebaf1e7ad0 (patch)
treea26c5a722946d200c7840cc99dd63defd9498948
parentdev-python/django-auth-ldap: 1.7 bump (diff)
downloadgentoo-f0eb78b0281f714dc7506eba410cd1ebaf1e7ad0.tar.gz
gentoo-f0eb78b0281f714dc7506eba410cd1ebaf1e7ad0.tar.bz2
gentoo-f0eb78b0281f714dc7506eba410cd1ebaf1e7ad0.zip
net-wireless/wpa_supplicant: update live
this is the LAST ebuild that will support gnutls or internal tls implementations. they don't work for any of the new wpa3 stuff, they aren't equivilent and never were. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-wireless/wpa_supplicant/metadata.xml1
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild31
2 files changed, 27 insertions, 5 deletions
diff --git a/net-wireless/wpa_supplicant/metadata.xml b/net-wireless/wpa_supplicant/metadata.xml
index 885b7c3d6bbd..4d369c2c3865 100644
--- a/net-wireless/wpa_supplicant/metadata.xml
+++ b/net-wireless/wpa_supplicant/metadata.xml
@@ -11,6 +11,7 @@
<flag name="eapol_test">Build and install eapol_test binary</flag>
<flag name="fasteap">Add support for FAST-EAP authentication algorithm</flag>
<flag name="hs2-0">Add support for 802.11u and Passpoint for HotSpot 2.0</flag>
+ <flag name="macsec">Add support for wired macsec</flag>
<flag name="p2p">Add support for Wi-Fi Direct mode</flag>
<flag name="ps3">Add support for ps3 hypervisor driven gelic wifi</flag>
<flag name="privsep">Enable wpa_priv privledge separation binary</flag>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index 72b9d2aa46d5..8a81bc1b5d49 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -18,7 +18,7 @@ else
fi
SLOT="0"
-IUSE="ap bindist dbus eap-sim eapol_test fasteap gnutls +hs2-0 libressl p2p privsep ps3 qt5 readline selinux smartcard ssl suiteb tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
+IUSE="ap bindist dbus eap-sim eapol_test fasteap gnutls +hs2-0 libressl macsec p2p privsep ps3 qt5 readline selinux smartcard ssl suiteb tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
REQUIRED_USE="smartcard? ( ssl )"
CDEPEND="dbus? ( sys-apps/dbus )
@@ -90,7 +90,7 @@ Kconfig_style_config() {
pkg_setup() {
if use ssl ; then
if use gnutls && use libressl ; then
- elog "You have both 'gnutls' and 'libressl' USE flags enabled: defaulting to USE=\"gnutls\""
+ elog "You have both 'gnutls' and 'libressl' USE flags enabled: defaulting to USE=\"libressl\""
fi
else
elog "You have 'ssl' USE flag disabled: defaulting to internal TLS implementation"
@@ -153,6 +153,11 @@ src_configure() {
Kconfig_style_config IBSS_RSN
Kconfig_style_config IEEE80211W
Kconfig_style_config IEEE80211R
+ Kconfig_style_config HT_OVERRIDES
+ Kconfig_style_config VHT_OVERRIDES
+ Kconfig_style_config OCV
+ Kconfig_style_config TLSV11
+ Kconfig_style_config TLSV12
# Basic authentication methods
# NOTE: we don't set GPSK or SAKE as they conflict
@@ -177,6 +182,13 @@ src_configure() {
Kconfig_style_config BGSCAN_SIMPLE
Kconfig_style_config BGSCAN_LEARN
+ if use macsec ; then
+ #requires something, no idea what
+ #Kconfig_style_config DRIVER_MACSEC_QCA
+ Kconfig_style_config DRIVER_MACSEC_LINUX
+ Kconfig_style_config MACSEC
+ fi
+
if use dbus ; then
Kconfig_style_config CTRL_IFACE_DBUS
Kconfig_style_config CTRL_IFACE_DBUS_NEW
@@ -233,25 +245,34 @@ src_configure() {
if use gnutls ; then
Kconfig_style_config TLS gnutls
Kconfig_style_config GNUTLS_EXTRA
+ Kconfig_style_config EAP_PWD n
+ Kconfig_style_config SAE n
+ Kconfig_style_config DPP n
else
#this fails for gnutls
Kconfig_style_config SUITEB192
Kconfig_style_config TLS openssl
+ Kconfig_style_config FST
if ! use bindist; then
#this fails for gnutls
Kconfig_style_config EAP_PWD
+ Kconfig_style_config FILS
+ Kconfig_style_config FILS_SK_PFS
# SAE fails on gnutls and everything below here needs SAE
# Enabling mesh networks.
Kconfig_style_config MESH
#WPA3
Kconfig_style_config OWE
Kconfig_style_config SAE
- #we also need to disable FILS, except that isn't enabled yet
+ Kconfig_style_config DPP
fi
fi
else
Kconfig_style_config TLS internal
+ Kconfig_style_config EAP_PWD n
+ Kconfig_style_config SAE n
+ Kconfig_style_config DPP n
fi
if use smartcard ; then
@@ -403,7 +424,7 @@ src_install() {
insinto /etc/dbus-1/system.d
newins dbus-wpa_supplicant.conf wpa_supplicant.conf
insinto /usr/share/dbus-1/system-services
- doins fi.epitest.hostap.WPASupplicant.service fi.w1.wpa_supplicant1.service
+ doins fi.w1.wpa_supplicant1.service
popd > /dev/null || die
# This unit relies on dbus support, bug 538600.
@@ -430,7 +451,7 @@ pkg_postinst() {
if use bindist || use gnutls; then
if ! use libressl; then
- ewarn "Using bindist or gnutls use flags presently breaks WPA3 (specifically SAE and OWE)."
+ ewarn "Using bindist or gnutls use flags presently breaks WPA3 (specifically SAE, OWE, DPP, and FILS)."
ewarn "This is incredibly undesirable"
fi
fi