summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-09-23 16:02:56 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-09-23 16:02:56 +0200
commitf0f3b12423277c551ad00114bc45b3fb039e5b0b (patch)
treeaedc296da0e69e89870998b5727c9df71f4fdd62
parentapp-emulation/docker: Remove old (diff)
downloadgentoo-f0f3b12423277c551ad00114bc45b3fb039e5b0b.tar.gz
gentoo-f0f3b12423277c551ad00114bc45b3fb039e5b0b.tar.bz2
gentoo-f0f3b12423277c551ad00114bc45b3fb039e5b0b.zip
app-shells/zsh-completions: Version bump to 0.31.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.31.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index 8a0f8516ec8e..0f4679f10c62 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1,2 +1,3 @@
DIST zsh-completions-0.29.0.tar.gz 251934 BLAKE2B 474f15cc8d492da0bbabc2a93edf316b9bb44bfb64ef8b8feae67fc381393b76701d9aca6eb64f6430f881b73a136985c8b17b392da139bd64afabe71e8183ba SHA512 4b2d79dd69576ce688fe24fe8c6e337319f2b96f5e668b9d58c8eb04f68198695a2652e8ad1e93a7ef9cf04cc53265c8db62f420b9ab6e1a2aff97ae24414945
DIST zsh-completions-0.30.0.tar.gz 227966 BLAKE2B 8f80be627f1fdb78f901c12fca5f3281562a161f295198344607ecc2187077576c3b37a7d8d764b8cef3607bf02226297ba58e27da0348ce6fa4c923d7072054 SHA512 a4469d13208aa93bff481a8754882ed272143c9ac38949eec38dd61d461b65faae8e51dcb73c6c3eb7216098322f5cf407a67f0ddab4c9e88a467e16ab249609
+DIST zsh-completions-0.31.0.tar.gz 247806 BLAKE2B 1923013feab9800f2dd0eef7b2263b0e252dd35b21d865e3f42f7946eeba2d1a882179e05fd16fdf473006646896ef87ca1da5cbc9bf69b52c66bcf99e82c010 SHA512 3f707e96c5d08103359304905cd36889d2b8dae82f0ea3781048a8fbd2f1db509abc1a181dc75215552214a59ee532d207897167fdb3850a5b1cc40e13b2b108
diff --git a/app-shells/zsh-completions/zsh-completions-0.31.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.31.0.ebuild
new file mode 100644
index 000000000000..574d178e5961
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.31.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}