summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-26 14:47:45 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-26 14:48:54 +0100
commitf17a5c062e0a6755f90d70827fb25f7bdd515bf6 (patch)
tree8e0676d1f19c866fda5739975a5f84ca4fea6b17
parentnet-libs/nghttp2: Removed old. (diff)
downloadgentoo-f17a5c062e0a6755f90d70827fb25f7bdd515bf6.tar.gz
gentoo-f17a5c062e0a6755f90d70827fb25f7bdd515bf6.tar.bz2
gentoo-f17a5c062e0a6755f90d70827fb25f7bdd515bf6.zip
media-gfx/scantailor: Version bump 0.9.12.2
Gentoo-bug: 590582 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-gfx/scantailor/Manifest1
-rw-r--r--media-gfx/scantailor/scantailor-0.9.12.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/scantailor/Manifest b/media-gfx/scantailor/Manifest
index a45659523dbd..b0ab6bae868b 100644
--- a/media-gfx/scantailor/Manifest
+++ b/media-gfx/scantailor/Manifest
@@ -1,2 +1,3 @@
DIST scantailor-0.9.11.1-boost-join-moc.patch 53044 SHA256 c00772facafdb696bf0e36ba216050cf3ec5b45c15e0099e6ef4935bffa9ba00 SHA512 77c6ee7988834c8694f9c09182fcdf87bdba64f3e69c9cc9b8347c4980a56c484a4368643f1c608ebbaeb469d4d6bc8d1a62f95fce18bc41dfce68137a457a61 WHIRLPOOL 0e5b04a65a5c47deeea6b3ec192549e50b22825df506bda2b87fbc1aa0254993a33c7c7907af1520c7e0ae4264a9a00b9e92d6114b1aee664408c69bb9bdcf00
DIST scantailor-0.9.11.1.tar.gz 1190198 SHA256 881647a4172c55a067a7b6687965441cf21176d79d93075b22a373ea9accd8d3 SHA512 cec327fd12144f7cee5043adfee3880c75fb147474e4c3b5166385f7a8f47cb5650ed2df930bbe1f4b8ac2c7229a887ecba1ca105b47b1023f5d3d7d7b54bdb4 WHIRLPOOL c064837bd4d5f4c3fbfa260493f3eccecff59910c934005148975f2f00511539ae0e66535d0a57bbf0458022c8ec249faa7f3df40ed8d89b2683530b885e4f6b
+DIST scantailor-0.9.12.2.tar.gz 1207379 SHA256 1f7b96bbe5179d46e332aea8d51ba50545fe7c510811e51588b6a4919e4feeab SHA512 d98603c5b3dfadeae3bda66d8b5ea085107edf9ee03efd299d50bf88a01f2b1092957f1ed4abe1a5d53b9028b7dec16dc5a8452d1a197fe0f3aaddeff6d02793 WHIRLPOOL 2ab46657538b5d95e2a564aa70775fdac8854136708f482c24c61507af217c75cb8974ace731a87b9a59d7e7da3788b23e28c178099fa479e2e01c3b767eb10c
diff --git a/media-gfx/scantailor/scantailor-0.9.12.2.ebuild b/media-gfx/scantailor/scantailor-0.9.12.2.ebuild
new file mode 100644
index 000000000000..9772950a2726
--- /dev/null
+++ b/media-gfx/scantailor/scantailor-0.9.12.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils eutils virtualx toolchain-funcs versionator
+MY_PV="RELEASE_$(replace_all_version_separators _)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A interactive post-processing tool for scanned pages"
+HOMEPAGE="http://scantailor.sourceforge.net/"
+SRC_URI="https://github.com/scantailor/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/libpng:0
+ media-libs/tiff:0
+ sys-libs/zlib
+ virtual/jpeg:0
+ x11-libs/libXrender
+ opengl? ( dev-qt/qtopengl:4 )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_configure() {
+ tc-export CXX
+
+ local mycmakeargs=(
+ -DCOMPILER_FLAGS_OVERRIDDEN=ON
+ -DENABLE_OPENGL=$(usex opengl)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${CMAKE_BUILD_DIR}" || die
+ virtx emake test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newicon resources/appicon.svg ${PN}.svg
+ make_desktop_entry ${PN} "Scan Tailor"
+}