summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-06 19:07:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-06 19:08:10 +0200
commitf24dc0ea0b049711226b4e0f8371948c5c99e83c (patch)
tree0ef80786f57581a76e5c46491609fcf1757f3508
parentdev-python/protobuf-python: Delete old versions (<3.15.8). (diff)
downloadgentoo-f24dc0ea0b049711226b4e0f8371948c5c99e83c.tar.gz
gentoo-f24dc0ea0b049711226b4e0f8371948c5c99e83c.tar.bz2
gentoo-f24dc0ea0b049711226b4e0f8371948c5c99e83c.zip
app-eselect/eselect-repository: Bump to v11, with py3.10 and tests!
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-eselect/eselect-repository/Manifest1
-rw-r--r--app-eselect/eselect-repository/eselect-repository-11.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-eselect/eselect-repository/Manifest b/app-eselect/eselect-repository/Manifest
index 6641869b1691..605676069b91 100644
--- a/app-eselect/eselect-repository/Manifest
+++ b/app-eselect/eselect-repository/Manifest
@@ -1 +1,2 @@
DIST eselect-repository-10.tar.gz 7123 BLAKE2B 786255e8b83c1348c16ec6e30495e7a0c305d48430712fd2bba28367d27d0e5eea1fe9176636f7896f48feebb71a9a3daa025fdc2f8032d2e6a3c59bd6b5c0c4 SHA512 4a03e1b9ddf3d8f79429e0a98cd03804867ba4594945ddda518be06c07e6e5737c77b8c57893a8cf5930548c96f0d436786d95bed624041ad52ab603348337b2
+DIST eselect-repository-11.tar.gz 8554 BLAKE2B c7bdd1559c310c492b2c00c7a7cb92d48ad24a69ff4485c1282c67b7dd211360fcda6d96eec2b9e734a1b4745f2a0fe9da1ff20d62bf1174a64b6016097ea634 SHA512 31b0b36122e580a018ca66d112cdddfbfe1568030fb9a20440450c17c759bfb872eb7ef99036a3dae14e8384a8f770354fd4cd362ed594408ae9e8dbbc6dea68
diff --git a/app-eselect/eselect-repository/eselect-repository-11.ebuild b/app-eselect/eselect-repository/eselect-repository-11.ebuild
new file mode 100644
index 000000000000..8a6bf3e77577
--- /dev/null
+++ b/app-eselect/eselect-repository/eselect-repository-11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-admin/eselect
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+ net-misc/wget"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )"
+
+src_compile() {
+ MAKEARGS=(
+ PREFIX="${EPREFIX}/usr"
+ SYSCONFDIR="${EPREFIX}/etc"
+ SHAREDSTATEDIR="${EPREFIX}/var"
+ ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+ )
+
+ emake "${MAKEARGS[@]}"
+ python_fix_shebang eselect-repo-helper
+}
+
+src_test() {
+ epytest
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}