summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-04-03 14:30:47 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-03 14:30:47 +0200
commitf2db8522dc3761c94b109a5c3338b82ad02cf835 (patch)
treefc3a0619bd9d4b40cf71204d39a7566852804acc
parentnet-vpn/6tunnel: Inherit python-any-r1 for tests (diff)
downloadgentoo-f2db8522dc3761c94b109a5c3338b82ad02cf835.tar.gz
gentoo-f2db8522dc3761c94b109a5c3338b82ad02cf835.tar.bz2
gentoo-f2db8522dc3761c94b109a5c3338b82ad02cf835.zip
sys-kernel/dracut-crypt-ssh: Respect CC/LDFLAGS
Closes: https://bugs.gentoo.org/726014 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-kernel/dracut-crypt-ssh/dracut-crypt-ssh-1.0.7.ebuild11
-rw-r--r--sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-ldflags.patch18
2 files changed, 27 insertions, 2 deletions
diff --git a/sys-kernel/dracut-crypt-ssh/dracut-crypt-ssh-1.0.7.ebuild b/sys-kernel/dracut-crypt-ssh/dracut-crypt-ssh-1.0.7.ebuild
index e244bc9a18bc..78fda89d1943 100644
--- a/sys-kernel/dracut-crypt-ssh/dracut-crypt-ssh-1.0.7.ebuild
+++ b/sys-kernel/dracut-crypt-ssh/dracut-crypt-ssh-1.0.7.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Early unlocking of encrypted systems via ssh for dracut"
HOMEPAGE="https://github.com/dracut-crypt-ssh/dracut-crypt-ssh"
SRC_URI="https://github.com/dracut-crypt-ssh/dracut-crypt-ssh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -23,4 +25,9 @@ RDEPEND="${DEPEND}
)
net-misc/dropbear"
-DOCS=("README.md")
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
+src_configure() {
+ tc-export CC
+ default
+}
diff --git a/sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-ldflags.patch b/sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-ldflags.patch
new file mode 100644
index 000000000000..5783ab2b516a
--- /dev/null
+++ b/sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-ldflags.patch
@@ -0,0 +1,18 @@
+# https://bugs.gentoo.org/726014
+--- a/modules/60crypt-ssh/helper/Makefile
++++ b/modules/60crypt-ssh/helper/Makefile
+@@ -17,11 +17,11 @@ clean:
+ rm -f *.o console_auth unlock crypttab-test
+
+ console_auth: auth.c
+- $(CC) $(CFLAGS) $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -o $@
+
+ unlock: crypttab.o unlock.o
+- $(CC) $(CFLAGS) -lblkid $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -lblkid $^ -o $@
+
+ crypttab-test: crypttab-test.c crypttab.o crypttab-test-data
+- $(CC) crypttab-test.c $(CFLAGS) crypttab.o -lblkid -o crypttab-test
++ $(CC) crypttab-test.c $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) crypttab.o -lblkid -o crypttab-test
+ ./crypttab-test