summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-05-25 08:08:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-05-25 08:08:00 +0000
commitf2dc8b75c2d37aadf13143c455cfabb9aa9103f1 (patch)
treeb167d4a36c18687f8a6de7bff372971acbd1bc1a
parentapp-admin/logrotate: add 3.20.0 (diff)
downloadgentoo-f2dc8b75c2d37aadf13143c455cfabb9aa9103f1.tar.gz
gentoo-f2dc8b75c2d37aadf13143c455cfabb9aa9103f1.tar.bz2
gentoo-f2dc8b75c2d37aadf13143c455cfabb9aa9103f1.zip
dev-db/postgis: Add 3.3.0_alpha1 (unkeyworded)
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--dev-db/postgis/Manifest1
-rw-r--r--dev-db/postgis/postgis-3.3.0_alpha1.ebuild140
2 files changed, 141 insertions, 0 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index 2b9229447ddf..951b373e17c2 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -4,3 +4,4 @@ DIST postgis-3.1.3.tar.gz 17273487 BLAKE2B 603be66476037fca5e75b00079a26b4beaa50
DIST postgis-3.1.5.tar.gz 17282333 BLAKE2B 3abe3b24ad0b8a9621c206f881a920ec4e37aa75ccc68ab8e4a43a372bb9047613c81d375051a948999068595de04f14bf4f0b7921b3f3894ff77a9d8c1c3063 SHA512 640196f4c983aeb1d661d98e099f4e2a47f32b15bfde21479b8fdb2aa5d12b4c564b0962973ec1a8dd64fbfac7cd7bc94d84376935294f23ba31d7501fe64a06
DIST postgis-3.2.0.tar.gz 16884722 BLAKE2B 118ae754199521e46508b404275bfe323465e5543ad8351d3dec3582800f6c475c30333b35ad48aac373f9d8e3875790c58858f638ee4ecb7465764703d07d40 SHA512 b49b2fbb88ec07981c0fd05400ad807e85553164023a4b47326c21f48b4e07827a183676c497ad6823dc3a6b97518e1d40906826b8a91739c96966d62858b2b5
DIST postgis-3.2.1.tar.gz 16883824 BLAKE2B 9c49ad518fb968dc4787bedf6480af29c3e70f986df8233ef034f117b8a8920ff6e39dab57813390b813a3d856476634b18e6ce324795839d019a11559155ff5 SHA512 e0ea3d2304e71c98dd045a8031946235d9c26a1310e1ffa556db10dfd18378957ee3d88608fba7ff482835d8c8b41d7f7bddaff1279ce0b50cd7634237465b31
+DIST postgis-3.3.0alpha1.tar.gz 17608824 BLAKE2B fd9bf2a7b081634e63ba6bd949bea950c7568d619cdd1b5ebecf825236cfac98cde949f7473e22d42916b2b9a41420d443ef33c1e8ba5a427714ab13635a0d5a SHA512 e3c2c9b27cb5c212c61f4fb591af4eb1e22ac0e4c3c3ca50ff0f6aa726cdb83f3d151efa1036042d1e1c336057964106e309f0723fc7136210b021ddcb0169ff
diff --git a/dev-db/postgis/postgis-3.3.0_alpha1.ebuild b/dev-db/postgis/postgis-3.3.0_alpha1.ebuild
new file mode 100644
index 000000000000..d98f7c40d8e6
--- /dev/null
+++ b/dev-db/postgis/postgis-3.3.0_alpha1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( {11..15} )
+POSTGRES_USEDEP="server"
+inherit autotools postgres-multi toolchain-funcs
+
+MY_P="${PN}-$(ver_rs 3 '')"
+
+if [[ ${PV} = *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osgeo.org/gitea/postgis/postgis.git"
+else
+ PGIS="$(ver_cut 1-2)"
+ SRC_URI="https://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="https://postgis.net"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="address-standardizer doc gtk static-libs topology"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+RDEPEND="${POSTGRES_DEP}
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/protobuf-c:=
+ >=sci-libs/geos-3.9.0
+ >=sci-libs/proj-4.9.0:=
+ >=sci-libs/gdal-1.10.0:=
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ virtual/imagemagick-tools[png]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.3-try-other-cpp-names.patch"
+)
+
+src_prepare() {
+ default
+
+ if [[ ${PV} = *9999* ]] ; then
+ source "${S}"/Version.config
+ PGIS="${POSTGIS_MAJOR_VERSION}.${POSTGIS_MINOR_VERSION}"
+ fi
+
+ # These modules are built using the same *FLAGS that were used to build
+ # dev-db/postgresql. The right thing to do is to ignore the current
+ # *FLAGS settings.
+ QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+ # bug #775968
+ touch build-aux/ar-lib || die
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ export CPP=$(tc-getCPP)
+
+ local myeconfargs=(
+ $(use_with address-standardizer)
+ $(use_with gtk gui)
+ $(use_with topology)
+ )
+ postgres-multi_foreach econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ local base_uri="https://postgis.net/docs/manual-"
+ if [[ ${PV} = *9999* ]] ; then
+ base_uri+="dev"
+ else
+ base_uri+="${PGIS}"
+ fi
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "${base_uri}/postgis_installation.html#create_new_db_extensions"
+}