summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-11-16 12:53:52 -0500
committerMichael Orlitzky <mjo@gentoo.org>2015-11-16 13:51:52 -0500
commitf30fcf63bb6b5a974a78135eb38609e69857d1b2 (patch)
tree1cda9365900ed4bdc6c78ebd6c5d6998e4344d13
parentdev-perl/ShipIt: Stable for amd64. Stable for ppc+x86 using the ALLARCHES pol... (diff)
downloadgentoo-f30fcf63bb6b5a974a78135eb38609e69857d1b2.tar.gz
gentoo-f30fcf63bb6b5a974a78135eb38609e69857d1b2.tar.bz2
gentoo-f30fcf63bb6b5a974a78135eb38609e69857d1b2.zip
dev-haskell/parallel-io: new package for performing parallel IO computations.
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-haskell/parallel-io/Manifest1
-rw-r--r--dev-haskell/parallel-io/metadata.xml16
-rw-r--r--dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild33
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/parallel-io/Manifest b/dev-haskell/parallel-io/Manifest
new file mode 100644
index 000000000000..121c2f6bebaa
--- /dev/null
+++ b/dev-haskell/parallel-io/Manifest
@@ -0,0 +1 @@
+DIST parallel-io-0.3.3.tar.gz 9435 SHA256 3a14c02b9b8b7c72577eb90a8dd72de75d99192def87d7aa79545ee4d6e80645 SHA512 4d2ddb9ad4b3b362e431774495fa7e4cc4476768257f2915f3a6e64c1872a5bcf880d71e1f678997a23fbf9cfa22bc2b38df9f2866897d3cbb6d35e65eb542db WHIRLPOOL 867e03bbe0d38ab3de7456424282046d7de8fd5be2671528c9004e418d93969d62fefa5ef728144f9483af8b573aaf1137900bf68987b062af739eeaf1e7d060
diff --git a/dev-haskell/parallel-io/metadata.xml b/dev-haskell/parallel-io/metadata.xml
new file mode 100644
index 000000000000..3e04410d16f1
--- /dev/null
+++ b/dev-haskell/parallel-io/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides combinators for sequencing IO actions onto a thread pool. The
+ thread pool is guaranteed to contain no more unblocked threads than a user-specified upper limit, thus
+ minimizing contention.
+
+ Furthermore, the parallel combinators can be used reentrantly - your parallel
+ actions can spawn more parallel actions - without violating this property of the thread pool.
+
+ The package is inspired by the thread &lt;http://thread.gmane.org/gmane.comp.lang.haskell.cafe/56499/focus=56521&gt;.
+ Thanks to Neil Mitchell and Bulat Ziganshin for some of the code this package is based on.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild b/dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild
new file mode 100644
index 000000000000..13d919781054
--- /dev/null
+++ b/dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Combinators for executing IO actions in parallel on a thread pool"
+HOMEPAGE="http://batterseapower.github.com/parallel-io"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#hackport: flags: -test -fuzz -benchmark
+
+RDEPEND=">dev-haskell/extensible-exceptions-0.1.0.1:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'random >= 1.0 && < 1.1' 'random >= 1.0 && < 1.2'
+}