summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZetok Zalbavar <zetok@openmailbox.org>2017-01-29 00:37:59 +0000
committerGöktürk Yüksek <gokturk@gentoo.org>2017-02-08 15:26:06 -0500
commitf37bdcf543a18e49b322aa0d14d7d8cb316fabc9 (patch)
tree5f71ec7411d4f9ead68375d49f6b5adc06fadf6d
parentapp-doc/pms: Depend on newer version of dev-tex/tex4ht. (diff)
downloadgentoo-f37bdcf543a18e49b322aa0d14d7d8cb316fabc9.tar.gz
gentoo-f37bdcf543a18e49b322aa0d14d7d8cb316fabc9.tar.bz2
gentoo-f37bdcf543a18e49b322aa0d14d7d8cb316fabc9.zip
net-im/qtox: switch live ebuild to cmake
Package-Manager: portage-2.3.3
-rw-r--r--net-im/qtox/qtox-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index e45d9c99c207..e763e12dcecc 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit eutils qmake-utils git-r3
+inherit cmake-utils eutils git-r3
DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
HOMEPAGE="https://github.com/qTox/qTox"
@@ -58,10 +58,10 @@ pkg_pretend() {
}
src_configure() {
- use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
- use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
- eqmake5 \
- PREFIX="${D}/usr" \
- ${NO_GTK_SUPPORT} \
- ${NO_X_SUPPORT}
+ local mycmakeargs=(
+ -DENABLE_STATUSNOTIFIER=$(usex gtk True False)
+ -DENABLE_GTK_SYSTRAY=$(usex gtk True False)
+ )
+
+ cmake-utils_src_configure
}