summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-24 08:06:30 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-24 12:12:08 +0200
commitf3a8cb28453763c86f04f31207f2a051f754225d (patch)
tree4a158ca8ead828528480556c4cb08dba647ee759
parentdev-python/lockfile: Add pypy3 support (diff)
downloadgentoo-f3a8cb28453763c86f04f31207f2a051f754225d.tar.gz
gentoo-f3a8cb28453763c86f04f31207f2a051f754225d.tar.bz2
gentoo-f3a8cb28453763c86f04f31207f2a051f754225d.zip
dev-python/testscenarios: Add pypy* support
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
index 5a70e5f2727d..82002ed23187 100644
--- a/dev-python/testscenarios/testscenarios-0.5.0.ebuild
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
inherit distutils-r1
@@ -17,8 +18,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linu
RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
python_prepare_all() {
# Remove a faulty file from tests, missing a required attribute