summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-26 21:01:01 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:10 +1300
commitf3da4f54cdc121a861f2b42bcf208a545b6d4148 (patch)
tree975eb7bc3b426030b22e3ee48f525e4030814f3c
parentdev-perl/Pegex: Bump to version 0.640.0 (diff)
downloadgentoo-f3da4f54cdc121a861f2b42bcf208a545b6d4148.tar.gz
gentoo-f3da4f54cdc121a861f2b42bcf208a545b6d4148.tar.bz2
gentoo-f3da4f54cdc121a861f2b42bcf208a545b6d4148.zip
dev-perl/Perl-Tidy: Bump to version 20171214.0.0
Upstream: - Continuation indentation now outdents closing parens in call chains - Add control flag for space between backslash and single/double quote - Add support for 5.26+ indented heredoc operator - Fix failure to call binmode - Fix using three-dot for locating config files using ENV - Improve vertical alignment - Stop vertically alignining // Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--dev-perl/Perl-Tidy/Manifest1
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Manifest b/dev-perl/Perl-Tidy/Manifest
index 627c36e3b2a0..b3aa7bde39af 100644
--- a/dev-perl/Perl-Tidy/Manifest
+++ b/dev-perl/Perl-Tidy/Manifest
@@ -1,2 +1,3 @@
DIST Perl-Tidy-20160302.tar.gz 428484 BLAKE2B 39fa56e9882e163c3630c979ab009fcd5b653021b880fa0632ae4e29af1a765cdceb1fd43751928eb26fb0269ba7c5f724161b5de98dbdd167a42712abc78d04 SHA512 68c7cef5723df717b5b314bee2bd76f29f49194479da993764cd127ced750d5cd8193b0c6c71c19c627687385d20d3e51ea01fcd81ec69374c7edb253bcac4f1
DIST Perl-Tidy-20170521.tar.gz 432394 BLAKE2B b791abb6213d7c8af42a1298854da81c7d03677b1fc08b101f43dcba43cb5ea68f8d8ecf290e69c057774754b3cd699caa21629d1e30fc4c8e13eeda72af7ba5 SHA512 5382162346e2eb1276d4790ed03208e52bfb82ecc2bc63facd5dd81e247872ff209a5aba7718997d426bd1aad5a3fc7434117b60f53dc2eaf9993df6ed9cb1e8
+DIST Perl-Tidy-20171214.tar.gz 435256 BLAKE2B 03e7ec8e7d76e6de68a54cd474f192b24ec4eaea563dae185b1723f80ac86df7c03bafbfcdcdffc0e3a18d2b57acf3f40321637fc66a64f1d0f72988e19a7e81 SHA512 bc561146f184dd0023de44741cafdcf6882ef553ed2e0c0ec8cd9a234f45b76638b4dc7edde0abfc36e4cc1f84ef908c35dc63f776de65e2abd938d35563cc65
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
new file mode 100644
index 000000000000..b3ffc3289260
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20171214
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing pod is bad because perldoc can't decompress
+ # bzip2 automatically, and `less` can't render perldoc
+ docompress -x /usr/share/doc/${PF}/stylekey.pod
+ docompress -x /usr/share/doc/${PF}/tutorial
+
+ docinto ''
+ dodoc docs/stylekey.pod
+
+ docinto tutorial
+ dodoc docs/tutorial.pod docs/testfile.pl
+}