summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Porta <vindex17@outlook.it>2016-09-04 15:38:41 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-09-08 15:12:50 +0200
commitf3ea28e90b802e13b2f02e439751bd3b8efc79f2 (patch)
tree885e2a8be93c5099748abde9c45e3b4b032eaedd
parentcmake-utils.eclass: print feature summary (diff)
downloadgentoo-f3ea28e90b802e13b2f02e439751bd3b8efc79f2.tar.gz
gentoo-f3ea28e90b802e13b2f02e439751bd3b8efc79f2.tar.bz2
gentoo-f3ea28e90b802e13b2f02e439751bd3b8efc79f2.zip
dev-util/cmake: use system cmake to build when available
Closes: https://github.com/gentoo/gentoo/pull/2236 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-util/cmake/cmake-3.6.2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-util/cmake/cmake-3.6.2.ebuild b/dev-util/cmake/cmake-3.6.2.ebuild
index aded1dcbf925..afc6671bf564 100644
--- a/dev-util/cmake/cmake-3.6.2.ebuild
+++ b/dev-util/cmake/cmake-3.6.2.ebuild
@@ -45,8 +45,6 @@ S="${WORKDIR}/${MY_P}"
SITEFILE="50${PN}-gentoo.el"
-CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
-
PATCHES=(
# prefix
"${FILESDIR}"/${PN}-3.4.0_rc1-darwin-bundle.patch
@@ -79,6 +77,11 @@ cmake_src_bootstrap() {
par_arg="--parallel=1"
fi
+ # disable running of cmake in boostrap command
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
# execinfo.h on Solaris isn't quite what it is on Darwin
if [[ ${CHOST} == *-solaris* ]] ; then
sed -i -e 's/execinfo\.h/blablabla.h/' Source/kwsys/CMakeLists.txt || die
@@ -122,18 +125,15 @@ cmake_src_test() {
src_prepare() {
cmake-utils_src_prepare
- # disable running of cmake in boostrap command
- sed -i \
- -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
- bootstrap || die "sed failed"
-
# Add gcc libs to the default link paths
sed -i \
-e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
-e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
-
- cmake_src_bootstrap
+ if ! has_version ${CATEGORY}/${PN}; then
+ CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+ cmake_src_bootstrap
+ fi
}
src_configure() {