summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-02-12 22:35:48 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-02-12 22:36:04 +1100
commitf3ff448671e8102de87143905d9b847362f15997 (patch)
tree1849389d332bc32b713a46abb79f51f2032e816d
parentnet-libs/osptoolkit: Remove old (diff)
downloadgentoo-f3ff448671e8102de87143905d9b847362f15997.tar.gz
gentoo-f3ff448671e8102de87143905d9b847362f15997.tar.bz2
gentoo-f3ff448671e8102de87143905d9b847362f15997.zip
app-i18n/jfbterm: add patch from Fedora fixing build with gcc-5
Gentoo-bug: 571066 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-i18n/jfbterm/files/jfbterm-0.4.7-wrong-inline-gcc5.patch24
-rw-r--r--app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild3
2 files changed, 26 insertions, 1 deletions
diff --git a/app-i18n/jfbterm/files/jfbterm-0.4.7-wrong-inline-gcc5.patch b/app-i18n/jfbterm/files/jfbterm-0.4.7-wrong-inline-gcc5.patch
new file mode 100644
index 000000000000..974ccbc41307
--- /dev/null
+++ b/app-i18n/jfbterm/files/jfbterm-0.4.7-wrong-inline-gcc5.patch
@@ -0,0 +1,24 @@
+Source: http://pkgs.fedoraproject.org/cgit/rpms/jfbterm.git/plain/jfbterm-0.4.7-wrong-inline-gcc5.patch
+
+--- jfbterm-0.4.7/pen.c.inline_gcc5 2003-08-30 03:48:16.000000000 +0900
++++ jfbterm-0.4.7/pen.c 2015-02-09 10:36:47.182751545 +0900
+@@ -62,7 +62,7 @@
+ p->attr = q->attr;
+ }
+
+-inline void tpen_off_all_attribute(TPen* p)
++void tpen_off_all_attribute(TPen* p)
+ {
+ p->bcol = 0;
+ p->fcol = 7;
+--- jfbterm-0.4.7/pen.h.inline_gcc5 2002-07-17 01:21:23.000000000 +0900
++++ jfbterm-0.4.7/pen.h 2015-02-09 10:36:52.058705503 +0900
+@@ -58,7 +58,7 @@
+ void tpen_init(TPen* p);
+ void tpen_final(TPen* p);
+ void tpen_copy(TPen* p, TPen* q);
+-inline void tpen_off_all_attribute(TPen* p);
++void tpen_off_all_attribute(TPen* p);
+ void tpen_higlight(TPen* p);
+ void tpen_dehiglight(TPen* p);
+ void tpen_underline(TPen* p);
diff --git a/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild b/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild
index a1266429d3f4..b79f0ff20b57 100644
--- a/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild
+++ b/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,6 +24,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-sigchld-debian.patch"
epatch "${FILESDIR}/${P}-no-kernel-headers.patch"
epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-wrong-inline-gcc5.patch"
eautoreconf
}