summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-14 13:14:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-14 14:08:36 +0200
commitf49fe2883f93c81bd8a022db9c027c3e6cb1d4af (patch)
tree3fa72b349aab08e817cd382d5582a7375e229649
parentmail-client/balsa: Make repoman more happy (diff)
downloadgentoo-f49fe2883f93c81bd8a022db9c027c3e6cb1d4af.tar.gz
gentoo-f49fe2883f93c81bd8a022db9c027c3e6cb1d4af.tar.bz2
gentoo-f49fe2883f93c81bd8a022db9c027c3e6cb1d4af.zip
dev-ml/ocaml-cstruct: bump to 3.1.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index f5504580082b..b05a1500691a 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1,3 +1,4 @@
DIST ocaml-cstruct-3.0.1.tar.gz 205663 SHA256 1e1c731c8970a82f5947ab0ee73ec2d160df3cd0f5e752a25c2689448e13a7e2 SHA512 355f97f1b3a6e7812b9210e348e4544e0ae6f01bef6536808cdcfe32153f9e3b711d1e869990cbd0205d433a51c7463c10f410b59aae33c32dab7f35f5413c27 WHIRLPOOL 54daaf26d0882fd7c782102c0fb84f683497a6acfee04649e19b9c5c330d24192e710fcbf8dede9b5128474fa314109a87894d99b6f44349dbbca52a68f7a10b
DIST ocaml-cstruct-3.0.2.tar.gz 205713 SHA256 86dc71140eae007c540cec982211ef48ec776232f2b23dd0b639e0e82099d60b SHA512 041ff15c102036f1162a870534e4bf83477f988344cbf420d21cf589100ba8f2fa2ae5c7de7c16ef36e88a10d6bfac43f3a63c929b6d6d90ae12ad0027d1c76d WHIRLPOOL a249e394c868f916ec243e702bf3eed38fdb2a7f60649b3d1be46bbc1308b4c9a3ac9e5d58ca35726f5fa3320d1773952a8105c34725345854da6837c38c2ff2
DIST ocaml-cstruct-3.1.0.tar.gz 208552 SHA256 7392fd6e6f79229003511d004466fd4079970aa0f6963d94e9b21f2fe409f00b SHA512 90ce3b093e50e077b66ff15b8f2f756d66b278598c01dc46def5a660eeab38b54edf62e93d4dad6cfc801b264def77158c27c7a8582d68c9690956c517820cae WHIRLPOOL 0e6642a7ced461f89ade09ab83c8e097d554d92e661765ab631014bbeb16af7c49434ca1918d08223eb972922f638628be93851f7b08cd4cea96860c1e380b2a
+DIST ocaml-cstruct-3.1.1.tar.gz 208725 SHA256 0b4469b17daaf7e6423962f2ad3ea02f4d4e35a7b92acb404afa6738570be3d6 SHA512 22ec8fe027dbebee537ff950c2aa9a494d0c4c000d8c4df848eae157b1c9502b73c208bb92c21fa4c13ba0291b7750de31e4c96b3a0571397402f841c3e01c21 WHIRLPOOL 287df0058f4291e2cbeb716f9a26aa7475ddcbfce6d1373c3d7a82d9c49d6c4d167de13298525f94414a9bcff2abff5e6d909a5de25d5063711a5a70f504d2ea
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
new file mode 100644
index 000000000000..39b192f16a3c
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx test"
+
+RDEPEND="
+ async? (
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core_kernel:=
+ )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ >=dev-ml/ppx_tools_versioned-5.0.1:=
+ )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+get_targets() {
+ local tgt="cstruct,cstruct-unix"
+ use lwt && tgt+=",cstruct-lwt"
+ use async && tgt+=",cstruct-async"
+ use ppx && tgt+=",ppx_cstruct"
+ echo "${tgt}"
+}
+
+src_compile() {
+ jbuilder build -p $(get_targets) || die
+}
+
+src_test() {
+ jbuilder runtest -p $(get_targets) || die
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall cstruct
+ oinstall cstruct-unix
+ use lwt && oinstall cstruct-lwt
+ use async && oinstall cstruct-async
+ use ppx && oinstall ppx_cstruct
+}