summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-08 20:50:36 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-08 20:50:57 +0300
commitf4b00a382f4e6b26804b5f94b67baeddfe5509b9 (patch)
treec94c6944dea05d24d439f348a58b1c8f70fa0d7d
parentdev-db/mariadb: Drop old (diff)
downloadgentoo-f4b00a382f4e6b26804b5f94b67baeddfe5509b9.tar.gz
gentoo-f4b00a382f4e6b26804b5f94b67baeddfe5509b9.tar.bz2
gentoo-f4b00a382f4e6b26804b5f94b67baeddfe5509b9.zip
app-laptop/thinkfan: Version bump (v1.0.2)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-laptop/thinkfan/Manifest1
-rw-r--r--app-laptop/thinkfan/thinkfan-1.0.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/Manifest b/app-laptop/thinkfan/Manifest
index 444109d9ddec..e5a21da3f867 100644
--- a/app-laptop/thinkfan/Manifest
+++ b/app-laptop/thinkfan/Manifest
@@ -1,2 +1,3 @@
DIST thinkfan-0.9.3.tar.gz 39527 BLAKE2B e6a6d09493d94b4de9ada20dcc4b0251c5f2c148f7faa7f69c04fe2a279a9cfe253a0ea1a01fe94ed108e8731e2ba01edef5df10dfb887ea961a356dff733854 SHA512 d2a29f9cae636c22b66958f8ec50cb60a162d745c3967257bb5e20cc9e152894d4e8a66f897ffa4e49353eba4a42e3499bb9e554719974284089a46cfc6280d7
DIST thinkfan-1.0.1.tar.gz 77587 BLAKE2B 7a2d4d77be8a9abdafe2cdb8485c92dfe9850ad2309d45d0ac32e8c0e7e6db22ef6c2e16161cccbd6e6147497accc8ec3f5d4467dbe5d2fe6d7fdfd06bb3261f SHA512 61fac9e99f5a2974c5a80e2565956d203baf670dc4b97625389e91fe3fe4d026c07847c10e7d46a4f57914a8156aeea0141570202c0ce2b497f8a1daefa47d6e
+DIST thinkfan-1.0.2.tar.gz 77653 BLAKE2B 1b40553380f9b873883f0dc587665f24cd2e07de7a7e743cb9f99a3282f380da2258265a612b1c97d2945fed31aee0d6cbc30ea2a18c0b212e877e7635eda336 SHA512 d9133538096a7c5757f599adfebc8217aa7334a102573d6757f03b5c012a09d600be923930fd9d62f4afa591f5eb7a70a1c328004bddef85494d1a7ce56b648f
diff --git a/app-laptop/thinkfan/thinkfan-1.0.2.ebuild b/app-laptop/thinkfan/thinkfan-1.0.2.ebuild
new file mode 100644
index 000000000000..a3f978a1bda1
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-1.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils readme.gentoo-r1
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="https://github.com/vmatare/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart nvidia +yaml"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )
+ yaml? ( dev-cpp/yaml-cpp )"
+RDEPEND="${DEPEND}
+ nvidia? ( x11-drivers/nvidia-drivers )"
+
+DOC_CONTENTS="
+ Please read the documentation and copy an appropriate
+ file to /etc/thinkfan.conf.
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DUSE_NVML="$(usex nvidia)"
+ -DUSE_ATASMART="$(usex atasmart)"
+ -DUSE_YAML="$(usex yaml)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ readme.gentoo_create_doc
+}