summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-01-02 16:31:27 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-01-02 16:31:27 +0100
commitf4f18f22e022449d5917119396284da238e08a9a (patch)
treede77c5c1d6e5c0a764386d557c9003fcdbe49420
parentsci-libs/m4ri: simplify openmp check. (diff)
downloadgentoo-f4f18f22e022449d5917119396284da238e08a9a.tar.gz
gentoo-f4f18f22e022449d5917119396284da238e08a9a.tar.bz2
gentoo-f4f18f22e022449d5917119396284da238e08a9a.zip
net-misc/pyhoca-gui: 0.6.1.1 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-misc/pyhoca-gui/Manifest1
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/pyhoca-gui/Manifest b/net-misc/pyhoca-gui/Manifest
index 9f201a480ad5..f5da2e7b92b8 100644
--- a/net-misc/pyhoca-gui/Manifest
+++ b/net-misc/pyhoca-gui/Manifest
@@ -1,3 +1,4 @@
DIST pyhoca-gui-0.5.0.8.tar.gz 2064483 BLAKE2B 63bca5be8673ef4e274caf4e0813b73f5dc8af7818b7638b2ac7411bb1598272bab573bc55c6c5e48fc45cc185bad907594b99ee0c96546683ecd8dd1ef1e3f1 SHA512 35bcbe35056d718ec5b58733b8569fd40cd6843a6661cc19deed02287cf65e03b4812fc82bdb0d54b12a78d5547456463e8adf236d4a7f04e11d0d462fe3eded
DIST pyhoca-gui-0.5.1.0.tar.gz 2098593 BLAKE2B 942caadb43654dbd65cfb50722f17b93b2becd410b90fb888a5133974b66ae377ab568204288e3a72441b74ad3e08a31190d67452a41086802177cc6a8f01406 SHA512 ae4287ccf2aadc4a6557c3bf37d01eb2cdfa542803ece41df02b7b816ba5b0be918231b40dba3c39a850064ae39907befdef1b80180649446b49fc975abbe312
DIST pyhoca-gui-0.6.1.0.tar.gz 2098973 BLAKE2B fdd145bb8ba67d70571a2244bded2f5c30382725c21747778c7490a98cd85dd7e872aec9ba539d407764a9a3a38d590aed5742268ebc38aa9cfaa3fc5b5a679c SHA512 d2730aa52afd4a835e593f3d8bde84435abb67aa490bb05807353d8d102c1d85564c21decbaf04e5cf54ef4a376247cf4a5ba1f7c9baf96149dbea9e583ea9cb
+DIST pyhoca-gui-0.6.1.1.tar.gz 2099727 BLAKE2B 944ee3cd743d502ce320759b9200c74de13802e23aabc2a5fe5659e123e2bbc368bf8a216c73de2c2ed22408d8fe50b4b945cc0714d05e1cb0faa1e5617dd4b0 SHA512 e7e24d60c1e4ecca2201c2a25bfc8c5552e54e30a5f744c5bc9c36ba4050a64cbb8616ab2e035b34cd14c62702ff88e32c863cac8aef0f8f4cb18db1d2e737b6
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
new file mode 100644
index 000000000000..a484ce41375c
--- /dev/null
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go graphical client applet"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]
+ x11-libs/libnotify"
+DEPEND="${DEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+ find "${ED}" -name '*.pth' -delete || die
+}