summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-28 22:23:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-30 15:18:36 +0300
commitf4fd44d87f787294c804d69861161058b2534c0f (patch)
treeb1888246140b3682f0ee41e731c3c927e751c54c
parentdev-python/openstacksdk: enable py3.9 (diff)
downloadgentoo-f4fd44d87f787294c804d69861161058b2534c0f.tar.gz
gentoo-f4fd44d87f787294c804d69861161058b2534c0f.tar.bz2
gentoo-f4fd44d87f787294c804d69861161058b2534c0f.zip
dev-python/os-client-config: enable py3.9
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/os-client-config/os-client-config-2.1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/os-client-config/os-client-config-2.1.0-r1.ebuild b/dev-python/os-client-config/os-client-config-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..01f631cf7e9c
--- /dev/null
+++ b/dev-python/os-client-config/os-client-config-2.1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Client Configuation Library"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.13.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ >=dev-python/prometheus_client-0.4.2[${PYTHON_USEDEP}]
+ dev-python/python-glanceclient[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/test_get_all_clouds.patch
+)
+
+distutils_enable_tests unittest