summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Lothian <mike@fireburn.co.uk>2019-03-01 14:15:47 +0000
committerMatt Turner <mattst88@gentoo.org>2019-03-04 10:46:40 -0800
commitf56b2406d79bdad2a3fab0f58e56c5eedcec46b0 (patch)
tree5e82d25b971c8e259b00387738f9eff8f85cd2be
parentmedia-libs/mesa: Add vulkan-overlay-layer support to mesa-9999 (diff)
downloadgentoo-f56b2406d79bdad2a3fab0f58e56c5eedcec46b0.tar.gz
gentoo-f56b2406d79bdad2a3fab0f58e56c5eedcec46b0.tar.bz2
gentoo-f56b2406d79bdad2a3fab0f58e56c5eedcec46b0.zip
media-libs/mesa: Add Iris support to mesa-9999
This allows the i965 alternative Gallium Iris driver to be built Intel Gen8 / Broadwell or newer is required to use the Iris driver Closes: https://github.com/gentoo/gentoo/pull/11167 Signed-off-by: Mike Lothian <mike@fireburn.co.uk> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-9999.ebuild8
-rw-r--r--profiles/desc/video_cards.desc1
2 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 0d4b0abb567f..fb346d34912b 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -30,7 +30,7 @@ RESTRICT="
"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 imx intel nouveau vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 imx intel iris nouveau vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -45,7 +45,7 @@ REQUIRED_USE="
gles1? ( egl )
gles2? ( egl )
vulkan? ( dri3
- || ( video_cards_i965 video_cards_radeonsi )
+ || ( video_cards_i965 video_cards_iris video_cards_radeonsi )
video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
wayland? ( egl gbm )
@@ -53,6 +53,7 @@ REQUIRED_USE="
video_cards_intel? ( classic )
video_cards_i915? ( || ( classic gallium ) )
video_cards_i965? ( classic )
+ video_cards_iris? ( gallium )
video_cards_imx? ( gallium video_cards_vivante )
video_cards_nouveau? ( || ( classic gallium ) )
video_cards_radeon? ( || ( classic gallium )
@@ -414,6 +415,8 @@ multilib_src_configure() {
fi
fi
+ gallium_enable video_cards_iris iris
+
gallium_enable video_cards_r300 r300
gallium_enable video_cards_r600 r600
gallium_enable video_cards_radeonsi radeonsi
@@ -433,6 +436,7 @@ multilib_src_configure() {
if use vulkan; then
vulkan_enable video_cards_i965 intel
+ vulkan_enable video_cards_iris intel
vulkan_enable video_cards_radeonsi amd
fi
diff --git a/profiles/desc/video_cards.desc b/profiles/desc/video_cards.desc
index bfee3a2eee7f..741ce82fc36c 100644
--- a/profiles/desc/video_cards.desc
+++ b/profiles/desc/video_cards.desc
@@ -17,6 +17,7 @@ i915 - VIDEO_CARDS setting to build driver for Intel i915 video cards
i965 - VIDEO_CARDS setting to build driver for Intel i965 video cards
imx - VIDEO_CARDS setting to build driver for Freescale i.MX video cards
intel - VIDEO_CARDS setting to build driver for Intel video cards
+iris - VIDEO_CARDS setting to build driver for Intel video cards Gen8 / Broadwell or newer
mga - VIDEO_CARDS setting to build driver for mga video cards
newport - VIDEO_CARDS setting to build driver for newport video cards
nouveau - VIDEO_CARDS setting to build reverse-engineered driver for nvidia cards