summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-15 21:38:18 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-15 21:38:18 +0200
commitf5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd (patch)
treeb330b7ba50a915e73eac48ded38ab42e7bdf76a9
parentapp-crypt/acme: Sync live (diff)
downloadgentoo-f5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd.tar.gz
gentoo-f5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd.tar.bz2
gentoo-f5f69bb45ce1ec47c493b3eded4b9eba1dc27ecd.zip
dev-python/pytest-mock: Version bump to 1.6.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index d28aaa0aa4bf..f3ec09af0d32 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,2 +1,3 @@
DIST pytest-mock-1.2.zip 19461 SHA256 f78971ed376fcb265255d1e4bb313731b3a1be92d7f3ecb19ea7fedc4a56fd0f SHA512 9b87c72e9895a16d4829229a070ba2b8143be894dfbc804b1e882eb2cc5843d8da9db258b5a2b9f8ae6738d9d612dbf1bec16790c5f99c27d9f7554cb676f852 WHIRLPOOL 470832b4df4a9392b0cfcbba96b2a52379d7111af0236f5dbe4e22f4e303da248bf2f936b3b66ae0ff3a197f3c87b0419c54c115fe5c6543e255f11666d3031d
DIST pytest-mock-1.5.0.tar.gz 17199 SHA256 782f23f227874bac4cee878637c2af8efdd2c34c48fcbf9e79b00a0872056ffb SHA512 5b5acb3ae3040d37768692a5289be269d8e12a6188a2dddefb136bdb99f847bedee525d59ac49886a6a27032b672e442ee256410174777675bf92fc82505f807 WHIRLPOOL 7c9c2617944dbf02cce356d12650d89372db252bdf79b92db304bcb1337858a38ae4b9b640210190338feccf4de0cbd64ad1a2d7ffc411c9184e1cd09dd7ec17
+DIST pytest-mock-1.6.0.tar.gz 17780 SHA256 83a17cbcd4dbc7c6c9dc885a0d598f9acd11f2d5142e0718ed32e14538670c1f SHA512 c3b897be9156d57d7012e95b620c543500b849d7076224e3328d3783311210c57141dfb82c01bb98e5e419125dce0f68f6631bd610f4909f5ac1798458a7949f WHIRLPOOL 518c8732f722547a0a87f0e1dd4cf8c80272f4a62f238d5bb16766fe0340c8fc022e409f58e6aa8ed7cb17b33fe160574db199197c0466701fa7e7a668fb5116
diff --git a/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild b/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild
new file mode 100644
index 000000000000..32941be25b3c
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/mock[python_targets_python2_7]
+ )
+ python_targets_pypy? (
+ dev-python/mock[python_targets_pypy]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test test_pytest_mock.py || die
+}