summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-11-25 20:31:17 -0800
committerZac Medico <zmedico@gentoo.org>2019-11-25 20:31:17 -0800
commitf615248b2b83d774324f22d3a4a9aa01af10426f (patch)
treeba1bd1f5b1e3b5f6ac1d67c61ff0a8082d545a57
parentapp-emulation/libpod: add upstream VFS user xattrs patch (diff)
downloadgentoo-f615248b2b83d774324f22d3a4a9aa01af10426f.tar.gz
gentoo-f615248b2b83d774324f22d3a4a9aa01af10426f.tar.bz2
gentoo-f615248b2b83d774324f22d3a4a9aa01af10426f.zip
app-emulation/skopeo: add upstream VFS user xattrs patch
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/skopeo/Manifest1
-rw-r--r--app-emulation/skopeo/skopeo-0.1.40-r1.ebuild (renamed from app-emulation/skopeo/skopeo-0.1.40.ebuild)12
2 files changed, 12 insertions, 1 deletions
diff --git a/app-emulation/skopeo/Manifest b/app-emulation/skopeo/Manifest
index a2d4b48ca796..01fc9d0acf5f 100644
--- a/app-emulation/skopeo/Manifest
+++ b/app-emulation/skopeo/Manifest
@@ -1,2 +1,3 @@
+DIST containers-storage-1.14.0-vfs-user-xattrs.patch 14835 BLAKE2B 99c35933dcb25385ee83b80cf282c11c738d0e4d91216cc08a50522f6caa9bca5938299412908f16df404f99e80616a10b4c02c0ebc38240a987830ddaf15008 SHA512 62c7ed49728bd12b5706f59b0d4af3b18d90e8cfc2b06e681f84fe3f5d3e0cd5c0317147109c4e3ec4fec26f82c269af3c9813e47339ce102e4e97400b74627d
DIST skopeo-0.1.39.tar.gz 3850036 BLAKE2B e635be475f22cc25ab98e446424f4a6b0babe34f827a73f9c9c1533db782490e9af94e759ac78fbeeec1c0e1fa42eef9d09fb4e7ff1f4df654f65fe4c1a9f7b0 SHA512 c4aadc40f9d637c628cd96c204b3e9bc3a928c145521bed2e5046508fc936ff99442dda8b4a4cdd85c4d04e64a9ccee5ea8d563c6ebf4e6020d50d96b921716c
DIST skopeo-0.1.40.tar.gz 3907911 BLAKE2B 0a9ebcc9662036b1595149f0d19a46c0565b115d37b22c6410041eef3e6755b20561439596f1033dd6ce2c78a4948e358b2518003729873d5ab8ce9a7bec082c SHA512 161edb8afa961e48e314cf70a4fcebd971a45a50fc11eab6ec751ba4eb05a8be011d16b83c4ed1fa9d6336846da5f518da006d4476ee4e29a160c629820773d3
diff --git a/app-emulation/skopeo/skopeo-0.1.40.ebuild b/app-emulation/skopeo/skopeo-0.1.40-r1.ebuild
index 3ee26d3ab1ad..c42103170fb0 100644
--- a/app-emulation/skopeo/skopeo-0.1.40.ebuild
+++ b/app-emulation/skopeo/skopeo-0.1.40-r1.ebuild
@@ -7,7 +7,9 @@ inherit go-module bash-completion-r1
DESCRIPTION="Command line utility foroperations on container images and image repositories"
HOMEPAGE="https://github.com/containers/skopeo"
-SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+CONTAINERS_STORAGE_PATCH="containers-storage-1.14.0-vfs-user-xattrs.patch"
+SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/containers/storage/pull/466.patch -> ${CONTAINERS_STORAGE_PATCH}"
LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
SLOT="0"
@@ -25,6 +27,14 @@ RDEPEND="${COMMON_DEPEND}"
RESTRICT="test"
+src_prepare() {
+ default
+ sed -e 's| \([ab]\)/| \1/vendor/github.com/containers/storage/|' < \
+ "${DISTDIR}/${CONTAINERS_STORAGE_PATCH}" > \
+ "${WORKDIR}/${CONTAINERS_STORAGE_PATCH}" || die
+ eapply "${WORKDIR}/${CONTAINERS_STORAGE_PATCH}"
+}
+
src_compile() {
local BUILDTAGS="containers_image_ostree_stub"
set -- env -u GOCACHE -u XDG_CACHE_HOME \